Introduction

 Top Next

Bienvenue sur FileLocator Pro

FileLocator Pro est l'outil de recherche de fichiers primé de Mythicsoft.

FileLocator Pro offre une gamme complète de paramètres pour vous aider à localiser et comprendre les informations de votre ordinateur.

Que faire ensuite ? Reportez-vous à la section commencer pour une introduction rapide.

Nous voulons nous assurer que vous ayez une expérience positive avec FileLocator Pro alors n'hésitez pas à nous contacter avec toutes vos questions à :

techsupport@mythicsoft.com

Copyright © 2013 Mythicsoft Ltd. All rights reserved.
Help file version: 7.0

PDF and CHM versions of this help file are available here:
http://mythicsoft.com/filelocatorpro/help


Commencer

 Top Previous Next

Lorsque vous démarrez FileLocator Pro, votre écran devrait afficher quelque chose de similaire à ceci :

L'interface est divisée en trois sections principales :

NumberOne | Critères, utilisée pour entrer les critères de recherche. Si le mode Usagers Experts a été coché (par défaut), vous verrez I'interface avancée, sinon vous verrez l'interface de base.
NumberTwo | Liste des fichiers, qui liste des fichiers trouvés pendant la recherche.
NumberThree | Contenus, qui montre de nombreuses informations concernant la recherche et les fichiers trouvés qui sont actuellement sélectionnés dans la Liste des fichiers.

Note : Pour changer l'apparence de FileLocator Pro, utilisez les paramètres d'interface utilisateur.

Recherche

Lorsqu'une recherche est lancée, l'animation de recherche se lance. Lorsqu'une recherche est lancée dans le contenu des fichiers, une information montrant le nombre de données à chercher sera visible pour vous aider à estimer le temps de recherche.

NumberOne | Pendant une recherche de contenu, la progression montre le nombre de données à rechercher ainsi que le nombre restant à chercher.
NumberTwo | L'animation de recherche sera visible pendant la durée de la recherche.

Lorsqu'un fichier est trouvé, il apparaît dans la section Liste des fichiers. Lorsqu'une recherche est réalisée dans le contenu des fichiers, les lignes trouvées peuvent être vues en sélectionnant un ou plusieurs fichiers trouvés. Les lignes trouvées seront alors affichées dans l'onglet Contenu pour chaque fichier sélectionné.


Section Critères

FileLocator Pro fournit deux interfaces différentes, une pour les utilisateurs d'ordinateur confirmés, et l'autre pour les utilisateurs débutants qui ne souhaitent pas gérer les options de recherche les plus avancées. Pour basculer entre les deux interfaces, cliquez dans la boîte "Usagers expert".

Interfaces utilisateur :

· Interface avancée
· Interface basique

Sauvegarder

FileLocator Pro prend en charge plusieurs option de sauvegarde comme décrit dans les sections Sessions, Espaces de travail et Critères de recherche.


Interface avancée

Avec la case Usagers experts cochée, la section critères devrait ressembler à ceci :

Nom de fichier

Filtre de nom de fichier, ex.

*.doc;*.txt;*.xls

pour rechercher tous les fichiers doc, txt, et xls en utilisant le type d'expression par défaut expression DOS.

L'expression rationnelle équivalente serait alors

\.(doc|txt|xls)$

Pour exclure un groupe de fichiers, entrez le préfixe NOT: devant l'expression DOS, par ex. NOT:*.doc;*.txt;*.xls. Pour rendre le nom de fichier sensible à la casse, cliquez sur le bouton "Aa" (une coche apparaîtra lorsqu'activé).

Par commodité, il y a aussi quelques ensembles de types de fichiers prédéfinis dans la liste: seulement les Dossiers, seulement les Fichiers, Documents, Musique, Photos et Vidéos.

Quand un ensemble prédéfini est choisi le champ Nom de fichier est traité comme une Expression booléenne.

Contenant le texte

Spécifie les contenus à trouver dans les fichiers pour une recherche de contenus. Le type d'expression par défaut est Booléen.

Pour rendre le contenu sensible à la casse, cliquez sur le bouton "Aa" (une coche apparaîtra lorsqu'activé).

Note : Si le type d'expression est configuré sur "hachage de fichier", le champ d'entrée du texte pourra contenir un liste de valeurs de hachage séparées par des virgules, ou un raccourci vers un fichier contenant une liste de valeurs hachées, par ex.

5A9C9B42A16F5E1985B7B0A019114C7A,675C9B42A16F5E1985B7B0A019114C7A

ou,

=c:\FileHashTable.txt

Les algorithmes utilisés pour calculer le hachage, par ex. SHA1, MD5, sont spécifiés dans l'onglet options.

Regarder dans

Le champ "regarder dans" peut spécifier de nombreux critères pour la localisation de la recherche, incluant l'exclusion d'emplacements, les filtres de localisation, etc. (pour une description complète des caractéristiques avancées, reportez-vous à la section regarder dans). De multiples emplacements de recherche peuvent être séparés par un point virgule.

Les boutons "Parcourir les dossiers" et "Parcourir plusieurs dossiers" fournissent un mécanisme pratique pour sélectionner les dossier à rechercher. Cliquez sur le bouton "Parcourir plusieurs dossiers"...

...et la boîte de dialogue de dossiers multiples apparaîtra. Entrez chaque dossier sur une ligne séparée.

Pour plus d'informations sur les caractéristiques avancées de FileLocator Pro, veuillez lire les pages recherche avancée et filtres de recherches persistantes.

Dates

Les champs "Modifié avant" et "Après" sont utilisés pour faire une recherche par date de modification. Pour activer ce critère de recherche, cliquez soit sur le bouton approprié (par ex. Avant ou Après), soit sur l'icône de calendrier à côté du champ de valeur. Voyez la section sélection de date / d'heure pour plus d'informations.

Les autres onglets disponibles dans l'interface avancée sont :

Options | Options en rapport avec la recherche, comme le type d'expressions ou les algorithmes de hachage de fichiers.
Date | Recherche par date de dernière modification ou de création.
Attributs | Attributs pour filtrer la recherche, par ex. Lecture seule, Dossiers, etc.
Scripting | Scripts utilisateur pour la logique des recherches personnalisées.
Fichiers compressés | Recherche de fichiers compressés / archivés


Onglet options

Expression booléenne

Le type de recherche par expression booléenne définit si des expressions booléennes sont concordantes ligne par ligne ou dans le fichier entier.

Par exemple, "File AND Pro" en ligne par ligne trouvera seulement les lignes contenant à la fois File et Pro, et ainsi seulement les fichiers dans lesquels File et Pro apparaissent dans au moins une ligne. Toutefois, si l'option "à travers tout le fichier" est sélectionnée, le logiciel trouvera les fichiers dans lesquels File et Pro apparaissent tous les deux, n'importe où dans le fichier, qu'ils soient sur la même ligne ou sur plusieurs lignes.

L'option "permettre métacaractère" spécifie si les phrases d'expression booléenne traiteront les caractères * et ? comme étant des métacaractères. Pour plus d'informations, visitez la page expressions booléennes.

Recherche fichiers Outlook PST et MSG

La case "Fichiers Outlook PST et MSG" bascule vers une recherche de fichiers .PST et .MSG archivés. Par défaut, seul le texte contenu dans le corps du message sera fouillé, mais si l'option "rechercher pièces jointes" est cochée, les pièces jointes seront également fouillées. Par défaut, les courriels en HTML seront convertis en texte, mais si vous devez rechercher dans le HTML sous-jacent, décochez la case "supprimer le balisage HTML".

Pour plus d'informations, reportez-vous aux sections recherche outlook d'archives PST et recherche de fichiers MSG

Améliorer la recherche de fichier

Sélectionner l'option "documents hors ligne / PDS" demande à FileLocator Pro de faire un traitement supplémentaire des formats de documents hors ligne communs, qui sont enregistrés sur l'ordinateur. Si cette option n'est pas sélectionnée, FileLocator Pro cherchera seulement dans les données binaires des formats de fichiers.

Des paramètres supplémentaire sur la façon dont FileLocator Pro cherchera la disponibilité des types de fichiers documents en cliquant sur Paramètres... un lien qui ouvrira la boite de dialogue Paramètres de Recherche de Documents.

L'option Exclure des fichiers binaires exclura tout fichier contenant des caractères non-imprimables.

LA mise en cache

Comme le traitement supplémentaire nécessaires pour lire les formats de fichiers documents pourrait-être une opération qui prend du temps, FileLocator Pro dispose d'une fonctionnalité de mise en cache pour enregistrer temporairement le texte traité dans une base de données. Lorsque la fonctionnalité de mise en cache est activée FileLocator Pro vérifie d'abord la base de données de la cache pour le texte traité du fichier avant d'essayer de traiter le fichier en cours lui-même donnant ainsi des recherches plus rapides. La fonctionnalité de mise en cache peut être activée en cochant l'option Texte en cache.

Des paramètres supplémentaires pour la fonctionnalité de mise en cache sont disponibles en cliquant sur La Cache... un lien qui ouvrira la boite de dialogue Paramètres de mise en cache.


Onglet date

L'onglet Date permet de faire une recherche par date de dernière modification, de création ou d'accès.

Cliquer sur les icones de calendriers ouvrira la fenêtre de sélection de date / heure.

Note : Tout changement effectué dans les dates seront immédiatement reflétés dans l'onglet principal.


Onglet attributs

L'onglet attributs permet le filtrage de fichiers / dossiers en se basant sur leurs attributs.

Chaque attribut peut être une de ces trois valeurs :

-- | Ignorer les attributs
Marche | L'attribut doit être présent dans le fichier / dossier.
Arrêt | L'attribut ne doit PAS être présent dans le fichier / dossier.


Onglet scripting

Le scripting permet de personnaliser les nom de fichiers et algorithmes de concordance de l'engin de recherche grâce à n'importe quel script Active Scripting valide.

Il est possible de spécifier un script pour les critères de concordance des noms de fichier ou du texte contenu.

Paramétrez la valeur de Moteur sur le moteur de recherche approprié qui lira votre script Active Script. Deux moteurs de scripts sont listés dans le menu déroulant, JScript et VBScript, mais tout autre moteur de script peut être spécifié.

Utilisez le champ Parm pour ajouter des paramètres supplémentaires au script.

Le bouton 'Test' tentera de créer le moteur de script spécifié, d'y charger les scripts appropriés, et de faire un essai de script, par ex. isValidFileName( "c:\", "TestFile.txt" ).

Pour plus d'informations, veuillez visiter la page Scripting.


Onglet fichiers compressés

L'onglet fichiers compressés montre la liste des extensions de fichiers compressés / archivés.

Lorsqu'un format de fichier compressé est activé, FileLocator Pro traite tous les fichiers trouvés de ce type comme faisant partie de la hiérarchie de dossier. Par ex. c:\zips\file1.zip\compressed\doc.txt


Sélection date / heure

FileLocator Pro accepte différents formats de date / heure pour filtrer les fichiers en se basant sur la date / l'heure de modification. Pour aider à spécifier la bonne valeur, ouvrez la fenêtre Sélection de date / heure en cliquant sur les boutons de calendriers comme ci-dessous.

Les valeurs de date / heure correspondent à une des deux grandes catégories :

· Date / heure fixe - une valeur absolue de date ou d'heure qui reste la même pour les recherches ultérieures, par ex. 19/04/09 12:00.
· Date / heure relative - une valeur qui est relative au moment de la recherche, par ex. Aujourd'hui heure de départ.

La fenêtre montre comment la sélection actuelle évalue à ce moment précis. Cela est constamment mis à jour pour refléter les valeurs de la date et de l'heure relatives.

Date

Des dates relatives peuvent être :

Aujourd'hui (Défaut) | Date de la recherche. | ex. 25/02/09 (mercredi)
Début de la semaine | Premier jour de la semaine dans laquelle la recherche est lancée (le lundi est considéré comme étant le premier jour de la semaine). | ex. 23/02/09 (lundi)
Début du mois | Premier jour du mois dans lequel la recherche est lancée. | ex. 01/02/09
Début de l'année | Premier jour de l'année dans laquelle la recherche est lancée. | ex. 01/01/09
Fin de la semaine | Dernier jour de la semaine dans laquelle la recherche est lancée (le dimanche est considéré comme étant le dernier jour de la semaine). | ex. 01/03/09 (dimanche)
Fin du mois | Dernier jour du mois dans lequel la recherche est lancée. | ex. 28/02/09
Fin de l'année | Dernier jour de l'année dans laquelle la recherche est lancée. | ex. 31/12/09

Les dates peuvent être ajustées par un nombre précis de jours, mois, ou années. Par exemple, pour que la date de départ soit celle du premier jour de la semaine dernière, sélectionnez "début de la semaine" puis appliquez un ajustement "-1 semaine".

Heure

Des heures relatives peuvent être :

Maintenant | L'heure du lancement de la recherche. | ex. 13:24:52
Début de minute | L'heure du lancement de la recherche avec les secondes remises à zéro. | ex. 13:24:00
Début d'heure | L'heure du lancement de la recherche avec les minutes et les secondes remises à zéro. | ex. 13:00:00
Début de journée (Défaut) | L'heure est définie à 00:00:00 | ex. 00:00:00
Fin de minute | L'heure du lancement de la recherche avec les secondes à 59. | ex. 13:24:59
Fin d'heure | L'heure du lancement de la recherche avec les minutes et les secondes à 59. | ex. 13:59:59
Fin de journée | L'heure est définie à 23:59:59 | ex. 23:59:59

Les heures peuvent être ajustées par un nombre précis de secondes, minutes ou heures précis.

Note : Les date / heure relatives sont évaluées au moment de la recherche et seront fixées à cette valeur pendant toute la recherche. La date / heure sera évaluée de nouveau seulement au moment de la recherche suivante.


Paramètres de Recherche de Documents

La boite de dialogue Paramètres de Recherche de Documents est ouverte à partir de L'onglet options.

Remarque : Les extensions listées dépendront de l'ordinateur de l'utilisateur.

Les formats de fichiers avec des extensions de traitement enregistrés (des extensions spécialement conçues pour aider les programmes de recherche à traiter le format) sont affichés dans la liste. Si "Rechercher en profondeur" ou "Paramètres personnalisés de traitement" sont sélectionnés, FileLocator Pro utilisera les extensions enregistrées pour traiter le format de fichier avant la recherche. Si la recherche n'aboutit pas, ou que l'extension ne donne pas de résultats, FileLocator Pro recherchera également dans les données brutes du fichier si les options "Recherche en profondeur" ou "Rechercher aussi les données brutes des documents des dossiers traités" sont sélectionnées.


Paramètres de mise en Cache

La boite de dialogue Paramètre de mise en cache est ouverte à partir de l'onglet options.

Le cache est utilisée pour conserver le texte extrait des fichiers document traités, ce qui signifie qu'il n y a pas texte en cache issu de fichiers non traités tels que les fichiers d'extension .txt. La boîte de dialogue affiche la quantité de données utilisée par le cache, la taille maximale autorisée pour un seul document et également la règle d'expiration pour chaque document.

La taille maximale du document est relative à la taille du texte extrait et non à la taille du document d'origine et est par défaut d'environ 10 Mo.

L'expiration par défaut consiste à supprimer tous les éléments de la cache s'ils n'ont pas été référencés dans la recherche au cours des 60 derniers jours.


Interface basique

Avec l'option Usagers Experts décochée, la section des critères ressemble plus à l'outil de recherche classique de Windows :

Caractéristiques principales :

· Dans l'onglet principal, les champs Nom de fichier, Contenant texte et Regarder dans peuvent être remplis librement ou sélectionnés d'après une recherche précédente (note : seules les dernières 20 valeurs utilisées seront disponibles).
· La différence principale entre ceci et l'outil de recherche Windows est le bouton "Assistant de recherche", qui ouvre un assistant de recherche pour aider l'utilisateur à entrer les critères qu'il souhaite pour sa recherche.

Onglet Options

Caractéristiques principales :

· Types d'expression par Nom de fichier, Contenu ou Regarder dans.
· "Respecter majuscule / minuscule" spécifie si les recherches sont sensibles ou non à la casse.


Liste de fichiers

Lorsque des fichiers sont trouvés pendant la recherche, ils apparaissent dans la Liste des fichiers. Pour chaque fichier, son nom et sa localisation sont affichés. Tous les fichiers sélectionnés dans cette fenêtre seront affichés dans celle des Contenus.

FileLocator Pro possède des menus contextuels pour lister les opérations valides pour un fichier ou un groupe de fichiers sélectionné. Les menus contextuels travailleront sur des sélections de plusieurs fichiers, mais la liste des opérations valides sera réduite aux seules opérations communes à tous les fichiers sélectionnés.

La colonne des filtres

Les fichiers peuvent être filtrés temporairement de la liste grâce à la colonne des filtres. Cliquez sur le bouton Filtre (en surbrillance ci-dessous) pour afficher les boîtes d'édition du filtre.

Les filtres sont appliqués immédiatement et peuvent contenir des expressions Booléennes ou de type spécifique:

Expressions Booléennes | Tous les filtres de la colonne peuvent accepter les Expressions Booléennes, par exemple: tour NOT (pont OR hameau)
Expressions Numériques | Des colonnes numériques, tels que la taille et les Hits, peuvent êtres filtrées du texte dans la colonne en utilisant des expressions Booléennes ou la valeur numérique sous-jacente. les symboles Supérieur à ou Inférieur à sont utilisés pour indiquer l'intervalle de filtrage numérique, par exemple: > 10 < 20. la colonne Taille accepte également les unités en octets, Ko, Mo, ou Go.
Expressions Date/Heure | la colonne Date/Heure, tel que les colonnes de la date de modification, de création, et du dernier accès, peuvent être filtrées du texte dans la colonne en utilisant les expressions Booléennes ou la valeur Date/Heure sous-jacente. les symboles Supérieur à ou Inférieur à sont utilisés pour indiquer l'intervalle de filtrage Date/Heure, par exemple: > 20 Sep 2010. les dates et les temps peuvent être indiquées sous n'importe quel format à condition que ce dernier soit accepté par la fonctionnalité du Traitement Date/Heure y compris les dates et les temps relatifs, par exemple < Aujourd'hui -3 ans.


Contenus

Tous les fichiers sélectionnés dans la liste de fichiers sont affichés dans la fenêtre Contenus.

Sommaire

L'onglet Sommaire fournit simplement un sommaire des dernières recherches :

Les quatre valeurs principales sont :

1. Trouvé : compte et donne la taille de tous les fichiers qui ont rencontré à la fois les critères du nom de fichier et du texte contenu, et qui sont donc affichés dans la liste des fichiers.
2. Recherché : compte et donne la taille de tous les fichiers qui ont été fouillés après avoir rencontré le critère du nom de fichier (s'applique seulement aux recherches de contenus).
3. Vérifié : compte et donne la taille de tous les fichiers qui ont été vérifiés dans le critère du texte contenu.
4. Statut : Statut de la recherche et temps total.

Résultats

Lorsqu'une recherche est lancée dans les contenus de fichiers, l'onglet Résultats montrera les informations trouvées, c'est à dire les résultats, pour chacun des fichiers sélectionnés (cliquez Sélectionner tout dans le menu Editer pour voir tous les résultats de tous les fichiers). Pour les recherches ne portant pas sur le contenu, seul le nom de fichier sera affiché.

Les lignes qui contiennent le texte de recherche sont affichées avec le résultat en surbrillance dans une couleur différente. La couleur de surbrillance est bleu par défaut, mais elle peut être changée dans le menu Choisir la couleur de surlignage dans le menu Édition.

Les boutons d'expansion à côté des lignes de texte peuvent être utilisés pour voir les lignes voisines du texte, comme montré ci-dessous.

Le nombre de lignes voisines peut être modifié dans la fenêtre Configuration.

Le fichier peut être ouvert à la ligne spécifiée soit en double-cliquant sur la ligne, soit en cliquant avec le bouton droit de la souris sur la ligne pour afficher le menu contextuel, puis en cliquant sur "Ouvrir dans une nouvelle fenêtre...". Pour ouvrir le fichier dans un éditeur externe (par ex. Notepad ++), sélectionnez "Ouvrir dans un éditeur externe..." dans le menu contextuel. Pour plus d'informations, visitez la page Paramètres éditeur.

Note : Lorsque les contenus des fichiers sont affichés, le numéro de ligne pour chaque ligne trouvée est également affiché. Ce numéro de ligne est estimé en comptant les marqueurs de fin de ligne dans le fichier, c'est pourquoi le numéro de ligne peut ne pas être précis si le fichier ne contient pas d'informations textuelles.

Texte

Pour voir les résultats dans le fichier, utilisez l'onglet Texte. L'onglet Texte intègre le Visionneur de fichiers interne dans les Contenus pour un prévisionnage rapide des fichiers :

Pour ouvrir le fichier dans une plus grande fenêtre, choisissez l'option "Ouvrir dans une nouvelle fenêtre..." depuis le menu contextuel, ou utilisez le raccourci Ctrl + Entrée.

Note : Par défaut, FileLocator Pro ouvre le fichier dans l'onglet Texte en double-cliquant sur un résultat dans l'onglet Résultats. Ce comportement par défaut peut être modifié dans la page Paramètres éditeur.

Petites images

Lorsque vous recherchez des images ou des fichiers graphiques, l'onglet Petites images vous donne un aperçu des fichiers sélectionnés.

Rapports

L'onglet Rapports offre un moyen facile pour exporter, imprimer ou résumer les données de la recherche.

Pour en savoir plus sur la fonctionnalité des rapports de 'FileLocator Pro', veuillez vous référer à la rubrique Rapports.

Masquer / verrouiller la vue

Si l'affichage des informations n'est pas important, il est alors plus efficace de masquer les contenus, en particulier avec les sélections de fichiers importantes. Pour masquer les contenus, sélectionnez "Masquer contenus" dans le menu contextuel de la fenêtre Contenus, ou sélectionnez l'option dans Fenêtre -> Visualiser contenus -> Station en dessous.

Pour afficher les contenus en dessous de la liste de fichiers, sélectionnez l'option "Station en dessous" dans le menu "Visualiser contenus" du menu contextuel, ou sélectionnez l'option dans Fenêtre -> Visualiser contenus -> Station en dessous.

Impression

L'onglet Résultats est la zone imprimable du logiciel et imprime tout ce que l'utilisateur a sélectionné dans la Liste des fichiers. Pour imprimer cet écran, cliquez sur Imprime ou sur Imprime prévisionner dans le menu Fichier.


Fichiers internes

La vue Fichiers internes est un affichage en lecture seule des fichiers trouvés, avec les résultats trouvés en surbrillance.

NumberOne

Recherche secondaire

Permet des recherches supplémentaires sur le fichier en entrant du texte dans le champ "Trouver" puis en appuyant sur Entrée.

NumberTwo

Barre de localisation

Donne un aperçu de la localisation des lignes affichées dans le Contenu du Fichiers en rapport avec le reste du fichier.

NumberThree

Contenus du fichier

Affiche le fichier ouvert à la ligne sélectionnée dans les Contenus, avec le texte trouvé automatiquement en surbrillance.

Menu Contenu

D'autres opérations sont disponibles dans le menu contextuel (menu du clic droit) :

Commandes disponibles :

Retour à la ligne | Active et désactive le retour à la ligne.
Copier | Copie le texte sélectionné (affiché en vert pâle) dans le presse-papiers. S'il n'y a pas de texte surligné, le mot où se trouve le curseur sera alors copié. Si le curseur n'est pas sur un mot valide, la ligne entière sera copiée.
Ouvrir dans un éditeur externe | Ouvre le fichier à la ligne actuelle dans l'éditeur externe spécifié dans les Paramètres de l'éditeur.
Ouvrir dans Visual Studio | Ouvre le fichier à la ligne actuelle dans Visual Studio (si Visual Studio est installé sur l'ordinateur).
Rechercher à nouveau | exécute la recherche originale une nouvelle fois pour les texte mis en surbrillance.
Trouver | Lance une recherche secondaire dans le texte actuellement sélectionné. Si aucun texte n'est sélectionné, la recherche utilisera le mot sur lequel se trouve actuellement le curseur.
Suivant | Passe au texte en surbrillance suivant.
Précédent | Retourne au texte en surbrillance précédent.
Surligner original | Remet en surbrillance les résultats de recherche originaux.
Surligner actuel | Remet en surbrillance les résultats de la recherche secondaire.
Définir police | Sélectionne la police utilisée par le visionneur. La police par défaut est Courier New.
Fichier | Affiche le menu shell Explorateur pour le fichier.

Surbrillance

Lorsqu'un fichier est ouvert, le texte trouvé original est surligné. Si une recherche secondaire est lancée, ses résultats seront également surlignés, mais dans une couleur différente. La surbrillance peut être activée et désactivée en utilisant soit le menu contextuel, soit les raccourcis Ctrl + Shift + O pour l'original et Ctrl + Shift + C pour les secondaires.

Lorsque les résultats des recherches originales et secondaires se chevauchent, le texte est surligné en rouge.

Navigation

Pour passer d'un résultat surligné à un autre, utilisez le menu contextuel ou appuyez sur F3 (ou sur Shift + F3 pour retourner au résultat précédent). La navigation se fait toujours vers l'occurrence suivante indépendamment du fait qu'il soit un résultat de la recherche principale ou secondaire. Toutefois, pour naviguer seulement entre les résultats de la recherche secondaire, désactivez la surbrillance pour la recherche originale.


Navigation de recherche

En utilisant la navigation de recherche, il est possible de parcourir et / ou de réutiliser les recherches précédentes. Tout comme les boutons suivant et précédent dans un navigateur web, les boutons de navigation de recherche naviguent en avant et en arrière à travers les recherches.

Le nombre de recherches à parcourir est déterminé par les paramètres de navigation de recherche dans les paramètres de l'historique.


Favoris

Les recherches lancées fréquemment peuvent être sauvegardées dans les favoris. Les favoris sont des recherches sauvegardées qui peuvent être rapidement chargées dans le panneau de recherche pour une navigation facilitée entre les différents types de recherches.

Pour accéder aux Favoris, cliquez sur le bouton Favoris dans le menu (ou appuyez sur Ctrl + D) :

Ceci ouvrira le panneau Favoris et affichera toutes les recherches enregistrées.

Ajouter un favori

Pour ajouter un favori, cliquez sur le bouton Ajouter favori :

qui ouvrira la fenêtre d'ajout de favori :

Il y a deux valeurs à associer au favori :

Description | Une description courte du favori
Tags | (Optionnel) Des tags qui peuvent être utilisés pour grouper les favoris et aider à filtrer les favoris.

Gérer les favoris

Lorsque vous cliquez sur un favori, il sera chargé dans la fenêtre de recherche actuelle. Pour charger le favori dans une nouvelle fenêtre de recherche, ouvrez le menu contextuel et cliquez sur "Ouvrir dans une nouvelle fenêtre".

Pour filtrer le nombre de favoris affichés, entrez des termes de recherche dans le champ "Recherche". Tous les favoris qui incluent les termes dans leur description ou leurs tags (ou les deux) seront affichés.

Importer les favoris

Les favoris sont simplement des recherches sauvegardées, ou fichiers .SRF, qui contiennent simplement plus de métadonnées pour leur description et leurs tags. C'est pourquoi vous pouvez importer des fichiers SRF existants en les copiant dans votre dossier Favoris. Pour ouvrir le dossier Favoris, cliquez sur le bouton Ouvrir le dossier des favoris :


Reports

Rapports

La fonctionnalité Rapports de FileLocator Pro offre un moyen facile d'exporter, d'imprimer ou de résumer les données de recherche.

Il existe quatre principaux rapports: Rapport de Liste des Fichiers, Rapport de Contenu, Rapport Résumé de Mots-clés et un Rapport de Mots-clés par Fichier. Tous les rapports peuvent être personnalisés afin d'inclure ou d'exclure différentes sections et colonnes.

Rapport de Liste des Fichiers

Le Rapport de Liste des Fichiers est très semblable à l'Aperçu de Liste des Fichiers et n'est disponibles que dans un style Tabulé. Le rapport ne fait que générer les données des fichiers, ce qui signifie qu'il ne génère aucun contenu trouvé.

Rapport des Contenus

Le Rapport des Contenus sert à rendre compte des contenus trouvés. Dans le style Standard, la sortie est similaire à la sortie affichée dans l'onglet Hits.

Le rapport peut également afficher les données dans un style Tabulé, ce qui serait le mieux adapté si vous devez exporter les données à un tableur.

Rapport Résumé des Mots-clés

Les statistiques sur les Mots-clés sont affichées dans le Rapport Résumé des Mots-clés. Chaque mot-clé est affiché avec le nombre d'occurrences de ce mot-clé trouvé pendant la recherche. Si les mots-clés comprennent des caractères génériques alors les statistiques sont ventilées dans chaque mot-clés séparé le modèle de mot-clé corresponde. La ventilation des mots-clés peut-être désactivée par la suppression de la colonne Hit de Mots-clés.

Rapport Mots-Clés par Fichier

Alors que le Rapport Résumé des Mots-clés affiche le hit des mots-clés combiné sur toute la recherche, le Rapport de Mots-clés par Fichier fait ventiler les statistiques des mots clés fichier par fichier

Options du Rapport

Pour personnaliser les données affichées dans chaque rapport, il vous suffit de cliquer sur le bouton Options (affiché ci-dessous en surbrillance).

Les Options du Rapport répertorient les colonnes pour chaque rapport et les entêtes à afficher pour le rapport. les options affichées ci-dessous concernent le rapport des contenus


Sessions, Espaces de travail et Critères de recherche

FileLocator Pro permet l'exportation des données de recherche dans différentes façons, mais bien que les fonctionnalités Exporter les Résultats et Rapports sont utiles pour l'exportation vers des formats courants, tels que Text, CSV, et HTML, ces formats ne peuvent pas être utilisés à recharger ces données dans l'application. Pour cette raison, FileLocator Pro est doté de trois options de sauvegarde différentes: Critères de Recherche, Sessions et Espaces de travail.

Critères de Recherche

L'option de sauvegarde la plus simple (et celle utilisée par la fonctionnalité Favoris ) qui consiste à ne sauvegarder que les Critères de Recherche en utilisant, à partir du menu, Fichier -> Sauvegarder les Critères. Le fichier SRF résultant peut-être utilisé pour remplir les champs des critères de recherche de FileLocator Pro.

Remarque: Le fichier SRF contient également les paramètres de configuration déterminés au moment de la sauvegarde, mais ils ne sont pas correctement réappliqués lors de la recharge du fichier SRF. Toute fois, en utilisant Basculer en mode ligne de commande '-pc' la configuration alors en cours peut être réinitialisée aux paramètres de configuration au même moment de la sauvegarde.

Sessions

Un seul onglet de recherche est considéré comme Session et peut être sauvegardé en utilisant, à partir du menu, Fichier -> Sauvegarder la Recherche. Le fichier FLSX résultant contient le les critères de recherche et les résultats de recherche non seulement pour la recherche en cours, mais également l'historique des recherches pour cet onglet de recherche (le cas échéant).

Espaces de travail

Un Espace de travail est constitué de toutes les Sessions et peut être sauvegardé en utilisant, à partir du menu, Fichier -> Sauvegarder l'Espace de travail. Le fichier FLWX contient les critères de recherche et les résultats de recherche pour toutes les sessions de recherche spécifiées.


Trucs et astuces

Rechercher plusieurs types de fichiers

Vous pouvez rechercher plusieurs types de fichiers en utilisant des expressions rationnelles ou DOS, par exemple :

Pour rechercher les types de fichiers .cpp, .h, .c, .INL, l'expression rationnelle sera :

\.(cpp|h|c|INL)$

OU, alternativement, une expression DOS serait :

*.cpp;*.h;*.c;*.INL

Exclure des types de fichiers

Entrez des expressions DOS avec le préfixe NOT: pour exclure certains types de fichiers. Par exemple, vous pouvez chercher tout sauf les fichiers COM et EXE en entrant le nom de fichiers dans l'expression DOS :

NOT:*.exe;*.com

Rechercher à plusieurs endroits

FileLocator Pro peut faire des recherches dans plusieurs destinations. Dans le champ Regarder dans, séparez chaque dossier avec un point-virgule, par ex. :

c:\winnt;c:\tmp

Utiliser des expressions dans le champ Regarde dans

Les expressions sont acceptées dans les chemins de dossiers. Pour utiliser cette caractéristique, utilisez le menu déroulant à côté du champ Regarder dans. L'expression ne sera pas traitée sur le chemin en entier mais seulement sur une partie, par ex. :

c:\usr\dev\.*\release

trouvera tous les dossiers nommés "release" deux niveaux plus bas que le dossier "c:\usr\dev".

Lancer FileLocator Pro depuis Windows Explorer

FileLocator Pro peut être intégré au shell de Windows grâce aux paramètre Extensions shell. Par exemple, lorsque vous recherchez des fichiers et dossiers dans Windows Explorer, vous pouvez lancer FileLocator Pro en cliquant droit sur le dossier et en sélectionnant "FileLocator Pro..." dans le menu contextuel, ou en utilisant le raccourci Ctrl + F.

Recherches communes

Sauvegardez vos critères de recherche souvent utilisés dans un fichier SRF, et mettez un raccourci vers ce fichier dans le menu Démarrer. Lorsque vous ouvrirez le raccourci, FileLocator Pro se lancera avec vos options de recherche préférées.

Note : Assurez-vous que FileLocator Pro soit bien associé avec les fichiers .SRF dans les paramètres d'intégration shell.

Spécifier des valeurs par défaut dans la ligne de commande

Vous pouvez spécifier les valeurs initiales de FileLocator Pro dans les paramètres de lignes de commande. Il y a même une option pour arrêter l'IGU (Interface Graphique de l'Utilisateur) et sauvegarder les résultats directement dans un fichier, ce qui est pratique lorsque vous intégrez FileLocator Pro avec d'autres logiciels. Pour voir une liste des paramètres de lignes de commande valides, allez sur Aide -> Ligne de commande parms. (ou lancez FileLocatorPro.exe -h).

Effet sur les performances du retour à la ligne

Le retour à la ligne est coûteux, surtout si vous essayez d'afficher beaucoup de contenus. Si la vue Contenus est lente, essayez de désactiver le retour à la ligne.

Effets sur les performance de la vue Contenus

Si vous sélectionnez un grand nombre de fichiers et que vous n'avez pas besoin de voir les contenus de ces fichiers, cela va bien plus vite de désactiver la vue Contenus, dans Fenêtre -> Visualiser contenus -> Cacher.

Effet sur les performances de deux phase de recherche

FileLocator Pro fonctionne en deux phases. La première phase collecte une liste de fichiers qui correspondent au critère du nom de fichier. La deuxième phase recherche les contenus des fichiers trouvés dans la première phase. Si plusieurs fichiers sont trouvés dans la première phase, FileLocator Pro pourra utiliser beaucoup de mémoire pour rechercher dans ces fichiers.

C'est pourquoi l'option de recherche "Une phase" dans l'onglet options demande à FileLocator Pro de rechercher dans le contenu de chaque fichier dès qu'il est trouvé, évitant ainsi la maintenance d'une liste de fichiers internes. Le seul inconvénient à la recherche en une phase est que FileLocator Pro ne pourra pas afficher de barre de progression. Utilisez cette option pour avoir plus de mémoire vive lors d'une recherche à travers un nombre important de fichiers (soit plus d'un million), mais normalement cette option n'est PAS requise.

Note : FileLocator Pro basculera automatiquement à la recherche en une phase s'il détecte que la recherche est trop volumineuse.

Rechercher des fichiers Unix et Mac

Les formats de texte Unix et Mac utilisent une séquence différente pour marquer la fin d'une ligne. Windows et DOS utilisent la séquence de caractères CR-LF (retour de chariot - saut de ligne) mais Unix utilise seulement LF et Mac utilise seulement CR. Pour demander à FileLocator Pro de rechercher une FDL alternative (fin de ligne), allez dans les paramètres de configuration (dans l'option Outils -> Configuration) et sélectionnez Traitement des caractères.

Tester vos expressions rationnelles

Testez vos expressions rationnelles dans Outils -> Testeur d'expressions rationnelles.

Vous trouverez plus d'informations en ligne dans la base de données Mythicsoft : http://www.mythicsoft.com/kb.


Questions / Commentaires ?

Vous trouverez plus d'informations en ligne dans la base de données Mythicsoft:

http://www.mythicsoft.com/kb

http://qa.mythicsoft.com/

Sinon, n'hésitez pas à nous contacter si vous avez des questions ou commentaires à :

http://www.mythicsoft.com/filelocatorpro/support

Ou par courriel : support@mythicsoft.com

Si vous souhaitez acheter un code d'activation, visitez le site web :

http://www.mythicsoft.com/filelocatorpro/buy

Merci d'utiliser FileLocator Pro.


Configuration

FileLocator Pro stocke toutes ses informations de configuration dans des fichiers XML localisés, par défaut, dans le dossier Mythicsoft AppData défini dans les paramètres de dossier. Les informations de configuration peuvent être changées en cliquant sur le bouton Configuration dans la barre d'outils ou en sélectionnant l'option "Configuration..." dans le menu "Outils".

Fenêtre de configuration

Les informations de configuration sont présentées en arborescence des groupes de configuration et des paramètres individuels pour chaque groupe.

Pour plus d'informations, visitez la page d'aide pour chaque groupe :

· Paramètres généraux
· Paramètres d'expression
· Paramètres d'éditeur
· Paramètres avancés
· Paramètres d'extensions


Paramètres généraux

Les paramètres généraux sont séparés dans les groupes de configuration suivants :

· Historique
· Affichage
· Recherche
· Traitement des caractères
· Intégration du shell
· Sons / alertes
· Localisation
· Interface utilisateur


Paramètres d'historique

Les paramètres d'historique contrôlent les informations dont FileLocator Pro se rappelle à propos des dernières recherches.

Pour effacer l'historique actuel, cliquez sur le bouton "Effacer historique...". Pour effacer l'historique à chaque fois que FileLocator Pro est fermé, cochez la case "Effacer l'historique à chaque arrêt".

Rappeler

Paramètres des options | Lorsque coché, FileLocator Pro restaure les paramètres d'options de la sessions précédente, comme le type d'expressions, les paramètres de casse, etc.
Taille de la fenêtre | Lorsque coché, FileLocator Pro restaure le positionnement de la fenêtre de la dernière session.
Charger la dernière recherche au démarrage | Lorsque coché, FileLocator Pro charge, au démarrage, les critères utilisés lors de la dernière recherche fructueuse. Cette option outrepasse efficacement les Paramètres d'options puisque la dernière recherche inclura toutes les options.

Listes des Tailles Maximales

Navigation de recherche | Le nombre maximal d'éléments affichés dans les menus déroulants de critères, par ex. nom de fichier, contenant texte, et regarde dans. Ces éléments sont enregistrés lors des différentes sessions de FileLocator Pro, c'est pourquoi la liste de la session précédente sera utilisée pour initialiser la liste de la nouvelle session.
Listes déroulantes | Le nombre maximal d'éléments affichés dans les menus déroulants de critères, par ex. nom de fichier, contenant texte, et regarde dans. Ces éléments sont enregistrés lors des différentes sessions de FileLocator Pro, c'est pourquoi la liste de la session précédente sera utilisée pour initialiser la liste de la nouvelle session.
Fichiers Récents | Le nombre de fichiers affichés dans la liste des Fichiers Récents sur le menu fichier.


Paramètres d'affichage

Les paramètres d'affichage contrôlent la manière dont FileLocator Pro affiche les résultats.

Afficher les lignes

Nombre de lignes maximales affichées par fichier

Limite le nombre de lignes qui seront visibles par fichier, pour éviter les recherches errantes dans de gros fichiers, consommant alors trop de mémoire. La valeur par défaut est 10 000 lignes.

Limite les caractères maximums affichés par ligne

Lorsque cochée, la case limite les caractères maximums affichés dans la vue Contenus pour chaque ligne (la ligne abrégée est centrée autour du texte trouvé sur la ligne).

Si elle est n'est pas cochée, la ligne entière, comme défini dans les Paramètres de traitement des caractères, sera affichée.

Lignes voisines

Définit le nombre de lignes voisines affichées pour chaque fichier trouvé. Les lignes voisines sont affichées dans la vue Contenus et peuvent être vues en cliquant sur l'icône "+" à côté de la ligne trouvée.

Les paramètres affecteront seulement les recherches futures, c'est pourquoi les anciennes recherches continueront à afficher les lignes voisines comme précédemment configuré.

Paramètres de la colonne de Liste de Fichiers

Afficher la fin du chemin d'accès - lorsque cochée, FlieLocator Pro donnera priorité à l'affichage de la fin du chemin d'accès si le chemin entier ne rentre pas dans la colonne Localisation. Les dossiers au début du chemin d'accès seront raccourcis à "...", par ex. C:\...\...\...\cpp\ProjectOne\.


Paramètres de Recherche

Les paramètres de recherche déterminent la façon dont FileLocator Pro recherche les fichiers.

Par défaut, FileLocator Pro recherche des fichiers en plusieurs fois. Il collecte d'abord les informations sur les fichiers, spécifiées dans le champ "nom du fichier", puis il recherche ces fichiers. Cela lui permet de montrer à l'utilisateur une progression plus précise.

Toutefois, il se peut que parfois, cette méthode ne soit pas utilisée. Par exemple, dans de très grosses recherches pour lesquelles des millions de fichiers sont fouillés, ou lorsque les fichiers sont temporaires et pourraient avoir été supprimés entre la première et la seconde phase, une recherche d'une phase peut être préférable. Pour forcer FileLocator Pro à fouiller chaque fichier une fois trouvé, basculez vers le mode "une phase".

Remarque : FileLocator Pro bascule automatiquement vers une recherche "une phase" s'il détecte que la recherche demande beaucoup trop de mémoire.

L'option "afficher le nombre de résultats" spécifie si FileLocator Pro affiche ou non le nombre de concordances trouvées dans chaque fichier dans la colonne "résultats" dans la liste des fichiers. Lorsque cette option est décochée, FileLocator Pro recherchera les fichiers en mode Juste à temps (JAT).

La recherche JAT recherche seulement une partie du fichier pour décider s'il est un résultat valide ou non. La dernière position de recherche dans le fichier est enregistrée, et le fichier n'est fouillé entièrement qu'une fois que tous les résultats sont nécessaires pour l'affichage ou l'exportation des données. Cette option peut être pratique pour rechercher dans de très gros fichiers et lorsque les résultats complets ne sont pas forcément nécessaires.


Paramètres de traitement des caractères

Les paramètres de traitement des caractères contrôlent la manière dont FlieLocator Pro gère les informations trouvées dans les fichiers.

Identifiants de Fin de Ligne (FDL)

Définit quels autres FDL FileLocator Pro doit utiliser. Normalement, un fichier texte Windows utilisera une combinaison CRLF (retour de chariot 0x0d, retour à la ligne 0x0a) pour indiquer la fin d'une ligne. Toutefois, d'autres systèmes ont des standards différents, comme par exemple seulement le CR ou le LF.

Caractères maximum par ligne - définit la limite de la longueur de la ligne si un caractère FDL n'est pas trouvé. Les lignes qui excèdent la longueur de ligne maximale sont séparées en plusieurs lignes, cependant le numéro de la ligne restera le même.

Contenant le Texte

Par défaut, la recherche basée sur le contenu n'inclura pas de nom de fichier comme faisant partie du contenu. Par ex. si un fichier nommé HistoiredeLondres.doc était recherché pour Tour AND Londres le fichier ne serait trouvé sauf si les deux mots à la fois apparaissent dans le texte du document, par ex. le nom du fichier document ne serait pas inclus comme faisant partie du texte. L'option 'Inclure le nom de fichier dans la recherche de contenu' est utilisée pour inclure le nom du fichier dans la recherche de contenu.

Spécial

Convertir en caract. 7 bits - lorsque cochée, FileLocator Pro utilise les premiers 7 bits de chaque caractère de données. Certaines anciennes machines de traitement de texte réservaient le 8ème bit de chaque caractère pour le formatage, ce qui, si non supprimé, cause des problèmes lors de la recherche des données. Ce paramètre permet d'ignorer le 8ème bit de chaque caractère.


Paramètres d'intégration shell

Les paramètres d'intégration shell contrôlent la manière dont FileLocator Pro s'intègre dans le shell de Windows.

Associer avec le type de fichier SRF | Associe FileLocator Pro avec l'extension de fichier SRF, l'extension par défaut pour un fichier de sauvegarde des résultats FileLocator Pro. Lorsque spécifié, double cliquer sur un fichier SRF lancera FileLocator Pro avec les critères de recherche du fichier SRF.
Ajouter au menu contextuel d'un dossier | Ajoute FileLocator Pro au menu contextuel des dossiers et disques. Cela donne un moyen pratique pour lancer FileLocator Pro dans un dossier donné en cliquant droit sur le dossier, puis en sélectionnant "FileLocator Pro..." dans le menu contextuel.
Ajouter au menu contextuel d'un fichier | Ajoyte FileLocator Pro au menu contextuel de tous les fichiers. Cela donne un moyen pratique d'utiliser FileLocator Pro pour rechercher dans une sélection limitée de fichiers en cliquant droit sur la sélection de fichiers, puis en sélectionnant "FileLocator Pro..." dans le menu contextuel.
Ajouter au menu démarrer chercher / trouver | Ajoute FileLocator Pro au menu de recherche Windows.
Remplacer le moteur de recherche par défaut | Lance FileLocator Pro à la place de la recherche Windows, lorsque Ctrl + F ou F3 sont appuyés dans l'explorateur Windows.
Permettre le lancement par touche d'accès rapide | Permet de lancer FileLocator Pro en utilisant le raccourci WinKey+Alt+F ou WinKey+Alt+F3. Note : L'aide par touche d'accès rapide est permise par l'utilisation d'une application légère nommée FLProHotKey, qui est rajoutée au code de démarrage du système.

Windows Vista : Puisque changer les paramètres du shell demandent d'avoir les privilèges d'administrateur, FileLocator Pro lance une application séparée, FLProShellAdmin.exe, pour réaliser les changements dans le shell. FLProShellAdmin.exe nécessite une élévation des privilèges, et il se peut donc qu'une demande UAC soit affichée si l'UAC est permise.


Paramètres de sons / d'alertes

La configuration des sons et des alertes fournit des notifications optionnelles visuelles ou audibles pour différentes interactions de FileLocator Pro.

Fichier trouvé

Jouer un son | Spécifie le fichier wave à jouer lorsqu'un fichier est trouvé.
Voir un message dans la barre des tâches | Spécifie si une fenêtre de notification s'affiche ou non dans la barre des tâches, montrant combien de fichiers ont été trouvés lorsqu'un fichier est trouvé.
Répéter pour chaque fichier trouvé | Permet au son et à la notification de se répéter à chaque fois qu'un fichier est trouvé (par défaut).

Recherche terminée

Jouer un son | Spécifie le fichier wave à jouer lorsqu'un fichier est trouvé.
Voir un message dans la barre des tâches | Spécifie si une fenêtre de notification s'affiche ou non dans la barre des tâches, montrant que la recherche est terminée et le nombre de fichiers trouvés pendant la recherche.


Paramètres de localisation

Les paramètres de localisation spécifient quelle langue doit être utilisée pour l'interface utilisateur.


Paramètres de l'interface utilisateur

Les paramètres de l'interface utilisateur contrôlent l'apparence de FileLocator Pro.

Défaut

FileLocator Pro est configuré pour utiliser le thème standard et une interface avec des onglets.

Classique

FileLocator Pro est configuré pour ressembler et agir comme FileLocator Pro version 5.x., qui utilise un thème classique et une interface MDI.

Personnalisé

Le thème et les options spécifiés par l'utilisateur pour utiliser une recherche par onglets ou non.

Pour modifier les paramètres d'ouverture de fichiers par défaut, utilisez les paramètres de l'éditeur.


Paramètres d'expressions

Les paramètres d'expressions contrôlent les nombreuses règles de correspondance pour tous les engins d'expressions de FileLocator Pro. Cette section est spéarée en plusieurs sections :

· Paramètres d'expressions booléennes
· Paramètres d'expressions DOS
· Paramètres d'expressions rationnelles
· Paramètres de hachage de fichiers


Paramètres d'expressions booléennes

Les paramètres d'expressions booléennes sont utilisés pour contrôler la manière dont les opérateurs LIKE et NEAR se comportent.

Sensibilité LIKE

L'opérateur LIKE peut être configuré à des sensibilités différentes lorsqu'il rencontre des mots similaires à ceux spécifiés dans la recherche. Les paramètres possibles sont :

Très similaire | Seules les petites différences dans les mots sont acceptées, par ex. un seul caractère ayant bougé de place.
Similaire | De plus grandes différences peuvent être acceptées, par ex. dans les longs mots, plusieurs caractère peuvent avoir bougé.
Approximatif | Les mots ont besoin d'avoir une petite similarité avec les termes recherchés.

Distance NEAR

Par défaut, l'opérateur NEAR nécessite que les termes recherchés soient à moins de 100 caractères l'un de l'autre. Ceci peut être changé pour une limite définie par l'utilisateur. Plus la limite est basse et plus le terme devront être proches les uns des autres, et vice versa.

Veuillez vous référer à la page expressions booléennes pour plus d'informations sur l'utilisation des expressions booléennes.

Analyse d'Expression

Lors de l'analyse d'une expression dans FileLocator Pro à partir d'une application tierce, tel que Microsoft Word, les guillemets pourraient apparaître stylisés, par ex. “Tower London” OR “Canary Wharf”. L'option de traitement des guillemets stylisés en tant que guillemets normaux demande à FileLocator pro de convertir ces guillemets en des guillemets standards. FileLocator Pro sépare généralement les expressions, par ex. "Tower London" OR "Canary Wharf".


Paramètres des expressions DOS

Les paramètres d'expressions DOS spécifient si oui ou non les règles de concordance d'expressions DOS suivront bien des règles de concordances DOS strictes.

Lorsqu'elles sont réglées sur "Syntaxe strictement conforme", les règles de concordance DOS forceront un contrôle des limites au début et à la fin de l'expression si un caractère générique est trouvé, par ex. :

l'expression locator* ne renverra pas le nom de fichier filelocatorpro.exe puisqu'il ne commence pas avec le terme "locator". Il faudra alors définir les paramètres de la recherche sur *locator*.

Lorsque l'option est désactivée, il est toujours possible de définir un contrôle des limites en utilisant les caractères "<" et ">", par ex. :

l'expression <locator*> est équivalente à l'expression DOS locator*

Veuillez visiter la page des types d'expression pour plus d'informations sur les expressions DOS.


Paramètres d'expressions rationnelles

Les paramètres d'expressions rationnelles définissent la syntaxe d'expression rationnelle à utiliser lors d'une recherche. Il peut s'agir de la syntaxe Perl des expressions rationnelles compatibles ou la syntaxe d'expression ordinaire Classique. Voyez types d'expressions pour plus d'informations.

Lors de la recherche d'un texte dans une langue étrangère, il pourrait être utile de 'Rassembler les Plages de Caractères' ce qui permet d'inclure les caractères en dehors de la plage standard a-z dans la plage, par ex. Années lors de l'utilisation de la plage [a-z]+


Paramètres de hachage de fichier

Les paramètres de hachage de fichier spécifient quels algorithmes de hachage FileLocator Pro doit utiliser lorsqu'il recherche un fichier haché spécifique.


Paramètres de l'éditeur

Éditeur par défaut

FileLocator Pro utilise par défaut son visualiseur de fichiers intégré pour afficher et ouvrir en lecture seule le contenu d'un fichier. Toutefois, il est possible de changer le visualiseur par défaut par un éditeur externe, en sélectionnant son emplacement et ses paramètres de ligne de commande. De plus, FileLocator Pro prend en charge l'ouverture de fichiers dans Visual Studio.

Éditeur externe

Pour utiliser une éditeur externe, spécifiez le chemin complet dans l'application de l'éditeur, puis, dans le champ situé en dessous, toutes les lignes de commande de paramètres à donner à l'éditeur lorsqu'il est ouvert. Pour activer les noms de fichier et numéros de ligne, incluez les commandes $(FILEPATH) and $(LINENUM).

Paramètres par défaut de l'éditeur - contient les paramètres par défaut pour mettre rapidement en place les lignes de commande par défaut pour quelques éditeurs communs. Pour utiliser ces paramètres par défaut, sélectionnez simplement l'éditeur dans le menu déroulant.


Paramètres avancés

Les paramètres avancés sont séparés en plusieurs groupes de configuration :

· Listes de fichiers
· Dossiers
· Points de jonction
· Fils / priorité
· Processeur XSLT


Listes de fichiers

La liste de fichiers indique si une valeur de critère peut être chargée depuis un fichier texte.

Exemple : Liste de nom de fichiers

Si le critère de nom de fichier permet la liste de fichiers (par défaut), alors au lieu de spécifier :

*.c;*.cpp;*.h;*.hpp;*.inl;*.res;*.rc

l'utilisateur devra spécifier :

=C:\FileLists\CodeFiles.txt

avec le CodeFiles.txt contenant quelque chose comme :

*.c

*.cpp

*.h

*.hpp

*.inl

*.res

*.rc

en ajoutant chaque expression sur une nouvelle ligne.

Exemple : Contenant une liste de texte

Pour recherche une liste de mots-clé dans un fichier, passez vers les listes de fichiers "contenant texte" puis spécifiez l'emplacement exact vers le fichier de mots clés dans le critère "contenant texte" dans l'onglet principal :

=C:\FileLists\Keywords.txt

avec le Keywords.txt contenant quelque chose comme :

Téléphone

E-mail

Contact

en ajoutant chaque mot clé sur une nouvelle ligne.


Paramètres de dossiers

Les paramètres de dossiers spécifient la localisation à laquelle FileLocator Pro enregistre ses configurations, logs et fichiers favoris.

Les localisations par défaut sont :

$(ApplicationData)\logs\

$(ApplicationData)\config\

$(ApplicationData)\Favorites\

La macro $(ApplicationData) évalue le dossier ApplicationData folder défini par Windows. Sur Windows 7, c'est généralement :

C:\Users\<id>\AppData\Roaming\Mythicsoft\FileLocatorPro

D'autres macros disponibles incluent $(FileLocatorProFolder) qui évalue la localisation de l'installation de FileLocator Pro, par ex. :

C:\Program Files\Mythicsoft\FileLocator Pro

Ceci peut être très utile lorsque vous installer FileLocator Pro vers une clé USB afin que toutes les informations de configuration soient sauvegardées sur la clé et non dans l'ordinateur.

L'information changée dans cette fenêtre est stockée dans le fichier master.xml localisé dans la racine du dossier d'installation de FileLocator Pro.


Points de jonction

Les points de jonction NTFS sont des liens vers d'autres dossiers sur le système. Ils sont très similaires aux liens symboliques, mais sont plus forts, c'est-à-dire que référer vers un point de jonction est, pour la plupart des utilisations, la même chose que référer vers le dossier lui-même.

Par défaut, FileLocator Pro recherchera les points de jonction, en dehors des points de jonction qui ont les attributs système et cachés (qui identifient normalement les points de jonction du système).


Paramètres de Gestion de Mémoire

Si FileLocator Pro détecte qu'il consomme une grande quantité de la mémoire, il peut tronquer les résultats de recherche pour réduire la quantité de mémoire nécessaire. Les Paramètre de Gestion de Mémoire vous permettent de personnaliser le point aux quel la troncature opère ou de désactiver carrément la fonctionnalité.


Paramètres de fils / priorités

Les paramètres de fils / priorités affectent la manière dont FileLocator Pro utilise le CPU.

Fils concurrents

Par défaut, FileLocator Pro recherche des fichiers en utilisant un seul fil pour chaque coeur de CPU, ce qui est généralement la configuration la plus efficace. Toutefois, il est possible de spécifier un nombre différent de fils de recherche en décochant la case "Gestion auto" et en spécifiant le nombre de fils.

Attention : si une machine a un seul disque dur assez lent, augmenter le nombre fils peut ralentir FileLocator Pro puisque d'autres recherches pourraient entraîner le disque dur à faire continuellement des recherches entre les différents secteurs du disque. Il n'est pas rare que la recherche de fichiers soit liée au I/O plutôt qu'au processeur.

Priorités de processus

On peut demander à FileLocator Pro de changer ses priorités de processus dépendament de l'état actuel de l'application :

· Premier plan - l'application a la priorité.
· Arrière-plan - l'application n'a pas la priorité, mais n'est pas réduite.
· Minimisé - l'application a été minimisée.

Par défaut, la priorité pour tous les états et "normal", qui est le paramètre par défaut des applications Windows. Les priorités alternatives sont :

· Haut - l'application est prioritaire par rapport aux procédés normaux, mais sa priorité est toujours en dessous de celle des programmes avec des priorités en temps réel.
· Bas - l'application n'est pas prioritaire par rapport aux procédés normaux, mais reçoit toujours une tranche de temps fiable de la part du CPU.


Paramètres du processeur XSLT

Sauvegarder les résultats donne l'option de lancer un transform XSL pour réaliser un formatage personnalisé. FileLocator Pro utilise MS XML Core Services pour accéder à la fonctionnalité transform, mais un autre DOM Prog Id peut être configuré ici.


Extensions

Par défaut, FileLocator Pro ouvre les fichiers dans leur format binaire brut. Alors que cela fonctionne bien pour des formats texte, d'autres formats, comme des zips ou des fichiers word, ne marchent pas aussi bien. Les extensions audent FileLocator Pro à gérer les formats non-textes afin que leur données soient bien fouillées.

Les extensions sont organisées par :

· IFilters - filtres basés sur les spécifications de filtre du service d'indexation de Microsoft.
· UTF-8 format par défaut - types de fichiers qui doivent être traités en UTF-8 par défaut.
· Documents compressés - types de fichiers qui sont stockés sous forme de fichiers ZIP.
· Extensions FileLocator Pro - filtres basés sur les spécifications de filtres de Mythicsoft.


IFilters

Le service d'indexation de Microsoft utilise des filtres, tout comme FileLocator Pro, pour interpréter des types de fichiers donnés en du texte facilement traitable. FileLocator Pro utilise ces filtres d'indexation, sans avoir besoin de lancer le service d'indexation, pour aider à convertir les fichiers en du texte facilement traitable.

La liste est des IFilters actuellement installés est montré dans l'onglet de paramètres de IFilters. Pour utiliser IFilter, activez-le dans les paramètres de recherche de fichiers améliorée, dans l'onglet options.

Une liste de IFilters gratuits peut être trouvée en lançant une simple recherche Internet.

Par défaut, des IFilters pour des fichiers de type HTML/XML ne sont pas utilisés du fait que beaucoup d'utilisateurs veulent qu'ils soient en mesure de rechercher les balises dans les documents HTML et non seulement le texte. Toute fois, si vous voulez rechercher que du texte contenu dans les fichiers HTML/XML, vous pourrez inclure des IFilters en vérifiant l'inclusion des IFilters pour les fichiers de type HTML/XML.

La Propriété de recherche des IFilters détermine quel type d'extension serait devrait être utilisé pour traiter un fichier si à la foi un IFilter et une extension de traitement spécifique à FileLocator Pro sont enregistrés. Par défaut, des IFilters sont Secondaires.


UTF-8 format par défaut

Si FileLocator Pro n'est pas capable de détecter l'encodage d'un fichier (dans l'en-tête BOM ou XML), il essayera de lire le fichier comme du texte ASCII. Toutefois, il est possible d'enrayer ce comportement et de spécifier l'UTF-8 comme format par défaut pour certains types de fichiers.


Lecteur de données brutes de fichiers compressés

Lorsqu'une extension de document, comme un document DOC, n'est pas active, FileLocator Pro essayera tout de même de lire les données brutes du fichier. Certains types de fichiers, toutefois, comme les documents Microsoft Office 2007 et Open Office, utilisent le ZIP pour compresser les données du document avant de les stocker, ce qui demande à FileLocator Pro de dézipper le document avant de pouvoir lire les données brutes qu'il contient.


Extensions FileLocator Pro

Les extensions aident FileLocator Pro à traiter les formats non-texte afin que leurs données soient correctement recherchées et ramassées.

L'instantané montre la configuration des extensions ZIP, qui est utilisée pour lire les fichiers au format ZIP. La configuration montre que l'extension ZIP doit être utilisée pour tous les fichiers avec une extension .zip ou .jar, mais elle peut être changée pour inclure d'autres formats ZIP.

Mode sans échec

Une extension est normalement lancée au même moment que FileLocator Pro, puisque c'est le moyen le plus rapide pour lui de communiquer avec l'extension. Toutefois, lancer l'extension dans le même espace de processus signifie que si l'extension rencontre un échec catastrophique, elle fera également planter FileLocator Pro. Pour éviter le plantage, les extensions à problème peuvent être lancées en mode sans échec, ce qui les lancera alors dans leur propre espace de processus, mais cela signifie que FileLocator Pro sera également plus lent.

Filtre de service d'indexation

Alors que FileLocator Pro fournit des extensions pour certains types de fichiers bien connus, par ex. DOC, XLS, etc., cela va parfois plus vite d'utiliser les filtres de service d'indexation s'ils sont disponibles. La case "Utiliser le filtre de service d'indexation" demandera à FileLocator Pro d'essayer de trouver un filtre de service d'indexation et de l'utiliser à la place d'une extension FileLocator Pro, si elle existe.

Note : Utiliser un filtre de service d'indexation ne demande pas à ce que le service d'indexation soit activé, mais signifie simplement que le filtre est installé.

Exclure un type de fichier des recherches de contenus lorsqu'inactif

Certains formats de fichiers, comme les ZIP, n'incluent pas de données binaires exploitables, cela ne sert donc à rien de rechercher à l'intérieur de ces fichiers si l'extension n'a pas été activée. Pour éviter de perdre du temps à rechercher dans ces fichiers, définissez l'indicateur "exclure".


Paramètres avancés

Plus d'informations sur les paramètres avancés :

· Ligne de commande
· Types d'expressions
· Expressions booléennes
· Scripting
· Regarder dans
· Filtres de recherche persistante
· Support unicode
· Chercher dans la recherche
· Recherche dans les archives outlook PST
· Recherche de fichiers MSG


Ligne de commande

Les valeurs de démarrage de FileLocator Pro peuvent être altérées alors que des données passent dans la ligne de commande. Si un fichier de sortie est spécifié, alors l'interface utilisateur actuelle ne sera pas affichée, et les résultats seront envoyés directement dans le fichier.

Les options de ligne de commande disponibles sont :

FileLocatorPro.exe [recherche sauvegardée] | -o [fichier de sortie] | -oa | -oc | -ol [no.] | -oe? | -of? | -os | -d [nom du dossier] | -c [contenant le texte] | -f [nom de fichier] | -cm | -fm | -s | -fd | -fx | -cr | -pa | -po | -ma [dateheure] | -mb [dateheure] | -h | -?

-c

Texte à rechercher dans les fichiers spécifiés (le champ "contenant le texte")

-ce?

Type d'expression du contenu : -ceb=Booléenne, cex=Expression rationnelle, -cee=Exact, -ceh=Expression rationnelle booléenne, -cew=Mot entier

-cf

Les expressions de contenu étendent le fichier (seulement avec les expressions booléennes)

-cm

Respecte la casse lors de la recherche de contenus

-d

Emplacement(s) à fouiller (champ Regarder dans), utiliser -dw pour l'emplacement de travail actuel

-f

Noms de fichier à rechercher

-fe?

Type d'expression du nom de fichier : -fed=DOS, -fex=Expression rationnelle, -feb=Booléenne, -fee=Exact, -feh=Expression rationnelle booléenne

-fm

Respecte la casse lors de la comparaison des noms de fichier

-fx

Le nom de fichier montre les noms de fichier à exclure

-le?

Type d'expression éregarder dans" : -leb=Booléenne, -lex=Expression rationnelle, -lee=Exact

-ma

Valeur modifiée après une date, choisir "maintenant" pour utiliser l'heure et la date actuelles

-mb

Valeur modifiée avec une date, choisir "maintenant" pour utiliser l'heure et la date actuelles

-o

Nom du fichier de sortie (lance la recherche sans montrer les résultats du streaming GUI de FileLocator Pro directement dans le fichier)

-oa

Ajouter au fichier résultant

-oc

Lignes du contenu de sortie

-oe?

Résultat de l’encodage: -oea=ASCII, -oe8=UTF-8, -oeu=Unicode

-of?

Format de sortie : -oft=Texte (défaut), -ofc=CSV, -ofb=Tab, -ofx=XML, -ofh=HTML, -ofxslt=XSLT

-ol

Nombre maximum de lignes trouvées par fichier résultant

-os

Lignes de sortie autour du texte

-pa

Toujours utiliser les paramètres de lignes de commande lors de la création d'une nouvelle recherche ou l'ouverture d'une recherche sauvegardée.

Note : Cette option peut être utilisée pour forcer une valeur de critère à être préréglée sur une certaine valeur, peu importe le moment auquel l'utilisateur crée une nouvelle recherche, et peu importe les valeurs utilisées précédemment.

-pc

Écraser la configuration avec une configuration stockée dans le fichier de critères de recherche sauvegardés.

Note : Les paramètres de configuration, comme les types de fichiers compressés actifs (ex. .zip) ou les paramètres de traitement des caractères, ne sont normalement pas chargés depuis le fichier SRF. Cette option force le chargement des paramètres de configuration depuis le fichier SRF, paramétrant efficacement FileLocator Pro à l'état identique dans lequel il était lors de la sauvegarde du fichier.

-po

Annuler les valeurs du fichier lors du chargement d'un autre fichier, ET spécifier les paramètres de ligne de commande

-r

Commencer la recherche immédiatement (sous-entendu par l'option -o)

-re?

Type d'expression rationnelle : -rep = synthaxe Perl, -rec = syntaxe classique

-resetui

Réinitialiser l'interface utilisateur à sa taille et position par défaut, incluant la barre d'outils, le menu, les fenêtres, etc.

-s

Rechercher dans les sous-dossiers

-view

Ouvrir un fichier dans le visionneur interne (utiliser -viewline et -viewcol pour spécifier les lignes et les colonnes)

-h or -?

Voir la fenêtre d'aide

Pour désactiver une option, ajouter "n" à l'indicateur, par ex. :

FileLocatorPro.exe -fmn désactive le respect de la casse lors de la comparaison des fichiers

Exemples :

Pour lancer FileLocator Pro avec le champ Regarder dans pré-rempli avec "C:\Documents and Settings\user\My Documents", les arguments de la ligne de commande seront :

FileLocatorPro.exe -d "C:\Documents and Settings\user\My Documents"

Pour lancer une recherche de fichiers qui correspondent à *.sys dans le dossier C:\WINDOWS sans lancer l'interface utilisateur habituelle mais plutôt en répartissant les résultats directement dans un fichier de sortie, les arguments de la ligne de commande seront :

FileLocatorPro.exe -d "C:\WINDOWS" -f "*.sys" -o "c:\temp\results.txt"

Pour lancer FileLocator Pro en désactivant la recherche dans les sous-dossiers et en activant le respect de la casse pour le contenu, les arguments de la ligne de commande seront :

FileLocatorPro.exe -cm -sn


Types d'expression

FileLocator accepte les types d'expression suivants :

· Booléenne
· Expression booléenne rationnelle
· Mot entier
· DOS
· Correspondance exacte
· Expression rationnelle
· Hachage de fichier

Expressions booléennes

Les expressions booléennes combinent des phrases individuelles de recherche en utilisant des opérateurs AND, OR, NOT, LIKE et NEAR. Pour plus d'informations, voyez expressions booléennes.

Expressions booléennes rationnelles

Les expressions booléennes rationnelles sont un type spéciale d'expressions booléennes qui permettent aux expressions rationnelles d'être utilisées avec des opérateurs END, OR et NOT. Pour plus d'informations, voyez expressions booléennes.

Expressions mot entier

Les expressions mot entier recherchent les phrases de recherche exactement comme elles sont tapées, ignorant les correspondances partielles. Puisque les expressions mots entiers sont un type spécifique d'expressions booléennes, les phrases de recherche individuelles peuvent être combinées en utilisant des opérateur AND, OR et NOT. Pour plus d'informations, voyez expressions booléennes.

Expressions DOS

Les expressions DOS sont généralement utilisées pour spécifier un groupe de fichiers. Utilisez un point virgule pour spécifier plusieurs groupes, par ex. :

L'expression *.cpp;*.h recherche des fichiers qui se terminent par .cpp ou .h

Les caractères "<" et ">" peuvent être utilisés pour correspondre au débout et à la fin du nom du fichier, par ex. :

L'expression <file* recherchera uniquement les fichiers qui commencent avec le terme file et NON les fichiers qui ont le terme file dans tout leur nom.

Pour plus d'informations, voyez expressions DOS

Texte vide

La correspondance avec les textes vides recherchera le texte comme il est entré (littéralement).

Expression rationnelle

FileLocator Pro peut être configuré pour utiliser la syntaxe d'expression rationnelle compatible avec Perl, ou la syntaxe classique de FileLocator Pro, dans l'onglet options. Les expressions rationnelles basiques peuvent être construites en utilisant l'assistant d'expressions

Syntaxe classique

La syntaxe d'expression rationnelle classique de File Locator Pro est basée sur les éléments d'expressions les plus utilisés. Vous trouverez plus d'informations dans la section démarrage rapide .

Syntaxe compatible avec Perl

La syntaxe d'expression rationnelle Perl est basée sur l'engin d'expressions Boost et inclut non seulement les fonctionnalités des expressions standard, mais également d'autres styles d'expression Perl qui sont détaillés ici : www.boost.org/doc/libs/release/libs/regex/doc/html/boost_regex/syntax/perl_syntax.html.

Hachage de fichier

Si le type de contenu est réglé sur "hachage de fichier", chaque fichier sera passé à travers plusieurs algorithmes (comme défini dans l'onglet options). Les hachages sont alors retournés comme des lignes dans un fichier texte, avec chaque hachage sur une nouvelle ligne. La valeur "contenant texte" spécifiée sera recherchée dans chaque hachage de la liste.


Expressions booléennes

L'engin d'expressions booléennes de FileLocator Pro prend en charge les recherches comme sur le web en utilisant les opérateurs AND, OR, NOT, NEAR, REGEX et LIKE. FileLocator Pro peut être configuré pour rechercher les expressions dans tout le fichier (par défaut) ou ligne par ligne, dans l'onglet options.

Exemple en ligne par ligne

L'expression work AND document recherchera les lignes qui incluent les mots work et document. Puis FileLocator Pro assume implicitement un "AND", l'expression peut également être écrite work document.

L'expression work OR document recherche des lignes qui incluent soit "work" soit "document".

L'expression work NOT document recherche des lignes qui incluent "work", mais pas "document".

Exemple en fichier entier

L'expression work AND document recherchera les fichiers qui incluent les mots work et document. Les mots peuvent être sur la même ligne ou sur différentes lignes à travers le fichier.

L'expression work NOT document recherche des fichiers qui incluent work mais pas document dans tout le fichier.

Note : les opérateurs AND, OR et NOT doivent être écrits en lettres capitales, sinon ils seront pris en compte comme étant des termes de recherche.

Des citations peuvent être utilisées pour rechercher des phrases littérales, par ex. :

"work document" recherche la phrase exacte work document.

Des parenthèses peuvent être utilisées pour spécifier un groupement de phrases, par ex. :

L'expression work AND (document OR letter) recherche des lignes qui incluent work et soit document soit letter.

Opérateur LIKE

Si l'orthographe du terme recherché n'est pas certain, ou possiblement mal épelé dans le texte recherché, l'opérateur LIKE pour être utilisé pour spécifier un terme de recherche approximatif. Par exemple :

LIKE necessary

recherchera necessary mais également d'autres légères variations, comme neccessary. Le niveau d'approximation peut être changé dans les paramètres de configuration.

Opérateur NEAR

Pour spécifier que deux termes de recherche doivent être proches l'un de l'autre dans le texte recherché, utilisez l'opérateur NEAR, par exemple :

work NEAR document

recherchera seulement les deux termes s'ils sont situés à un certain nombre de caractères l'un de l'autre (la distance maximale est spécifiée dans les paramètres de configuration)

Opérateur REGEX

Pour spécifier qu'un terme est une expression rationnelle, utilisez l'opérateur REGEX. Par exemple :

work AND REGEX "\d{5,6}"

recherchera tous les documents ayant le terme work et l'expression rationnelle \d{5,6} (ici un nombre avec 5 à 6 chiffres). Pour spécifier que ces termes doivent toujours être traités comme des expressions rationnelles, sans avoir besoin d'utiliser l'opérateur REGEX, utilisez le type d'expression booléenne rationnelle (voir ci-dessous).

Opérateur LINES

L'opérateur LINES limite les lignes qui sont recherchées pour les expressions suivantes. par exemple,

LINES:3-5 (tour AND londres)

recherche que les lignes 3, 4 et 5 pour l'expression

searches only lines 3, 4, and 5 for the expression tour AND londres.

Sous-expressions booléennes

Les expressions booléennes sont composées de sous-expressions. Le type de sous-expression dépendra du type d'expression choisi

Booléenne (pas de génériques1)

Chaque phrase est recherchée exactement comme elle est entrée, mais recherchera également dans les mots plus longs.

Par ex :

fish relèvera fish, fishing et selfish (par exemple).

Booléenne (pas de génériques1)

Permet les caractères génériques '*' et '?'. '?' cherchera tous les caractères seuls, et '*' recherchera zéro caractères ou plus jusqu'à la fin du mot.

Par ex :

fish* relèvera les mots fish, fishing, et selfish.

Les paramètres de génériques permettent également les barrières entre les mots, en utilisant les caractères "<" et ">" pour spécifier le début ou la fin du mot, par ex.

<fish> ne relèvera que le mot fish et pas fishing ni selfish. De même, fish> relèvera les mots fish et selfish mais pas fishing puisque le mot doit se terminer par fish.

Pour rechercher le premier texte littéral fish* ou fish> placez le terme de recherche entre guillemets, par ex. "fish*" ou "fish>"

Expression rationnelle booléenne

Chaque phrase est traitée comme une expression rationnelle. Si l'expression rationnelle inclut des espaces ou des parenthèses, utilisez les guillemets pour les grouper ensemble.

Ex :

trout.* OR "fish(es|ing)"

Mot entier

Chaque phrase est recherchée exactement comme elle est tapée.

Ex :

fish cherchera seulement le mot fish et non fishing ni selfish.

1 Les paramètres de génériques sont spécifiés dans l'onglet options (par défaut, les génériques sont acceptés).

Exemple : expression booléenne rationnelle

En utilisant le type d'expression booléenne rationnelle, les recherches d'expressions peuvent être combinées en utilisant les opérateurs AND, OR et NOT. Les expressions rationnelles sont évaluées sur chaque ligne, mais le comportement des combinaisons booléennes de ces résultats d'expressions rationnelles, ligne par ligne ou à travers le fichier entier, sera défini par les paramètres d'expressions booléennes dans l'onglet options.

Exemple en ligne par ligne

L'expression [0-9]+ AND document recherche des lignes qui incluent à la fois un chiffre et le mot document.

L'expression "[a-z]+@[a-z]+" NOT "\.(com|net)" recherche des lignes contenant des textes de type courriel, mais n'incluant pas .com ni .net. Notez l'utilisation de guillemets pour montrer le groupement d'expressions rationnelles (sinon les parenthèses auraient été traitées comme un groupement d'expressions rationnelles).

Exemple en fichier entier

L'expression "([0-9]+\.){3}[0-9]+" AND error recherche des fichiers contenant une adresse IP et le mot error quelque part dans le fichier, mais pas nécessairement sur la même ligne.

Des guillemets sont utilisés pour identifier les parties de l'expression qui sont des expressions rationnelles.

Note : A cause de la nature complexe des types d'expressions booléennes rationnelles, les recherches qui l'utilisent sont généralement plus lentes que pour les autres types d'expressions. C'est pourquoi l'utilisation d'expressions booléennes rationnelles est seulement recommandée lorsqu'elles sont vraiment nécessaires.


Expressions DOS

Les expressions DOS utilisent les génériques * et ? pour spécifier des groupes de fichiers, par ex. *.pdf pour spécifier un groupe de fichiers avec l'extension PDF. Toutefois, FileLocator Pro étend la fonctionnalité d'expressions DOS normale avec des caractères spéciaux supplémentaires :

Caractère | Description | Exemple
* | Correspond à zéro caractères ou plus | Tower*London - fichier / dossier contenant Tower suivi de London dans son nom.
? | Correspond à un caractère | *.as?x - fichiers avec une extension à quatre lettres qui commence par AS et se termine par X, par ex. Page.aspx ou Home.ascx.
< | Début de l'indicateur du fichier | <New - le fichier / dossier doit commencer par New, par ex. New York Trip.txt mais pas My New Recipes.
> | Fin de l'indicateur du fichier | LA> - le fichier / dossier doit terminer par LA, par ex. Parks in LA ou Details.SLA mais pas LAMP.
; | Étend la recherche en ajoutant un autre nom / groupe acceptable | *.pdf;*.txt;*.doc - fichiers avec des extensions PDF, TXT et DOC.
: | Restreint la recherche à un groupe / nom spécifique | *.pdf;*.doc:London - fichiers PDF ou DOC contenant London dans leur nom.
NOT: | Exclut un nom / groupe de la recherche | NOT:*.dll;*.exe;*.sys - tous les fichiers excepté DLL, EXE, et SYS.
| | Lier plusieurs expressions de recherche | *.pdf:London|*.txt:Tower - fichiers PDF files contenant London dans leur nom, ou fichiers TXT avec Tower dans leur nom.
" | Utilisé pour entrer un point virgule ";" ou spécifier une barrière de mot | "LA" - fichiers / dossier avec le mot LA dans son nom, par ex. LA Flight details.txt mais pas LAMP.txt.

Plus d'exemples

Vous recherchez... | DOS Expression
Fichiers / dossiers sans extensions | *.
Seulement les fichiers / dossier ayant le nom Area | <area>
Fichiers PNG, JPG, ou BMP contenant le mot France | *.png;*.jpg;*.bmp:France
Fichiers MP3 contenant les mots Rolling et Stone | *.mp3:Rolling:Stone
Fichiers PDF contenant soit le mot London, soit le mot Tower | *.pdf:London;Tower
Tous les fichiers qui ne sont pas des fichiers EXE ou DLL, contenant le mot Flower dans leur nom | NOT:*.exe;*.dll:Flower
Tous les fichiers TXT contenant un point virgule | "*;*.txt"


Scripting

FileLocator Pro prend en charge le scripting actif pour personnaliser les algorithmes de recherche de nom de fichier et de contenu du moteur de recherche.

Lorsqu'un utilisateur lance une recherche, FileLocator Pro :

· Regarde si un script est actif
· Crée le moteur de recherche pour scripting actif, comme spécifié par le Prog ID entré dans le champ "moteur".
· Charge le script dans le moteur de scripting.

Une fois que le script est chargé, FileLocator Pro lancera alors une fonction spécifique dans le script, dépendament du type de script :

· Si le script est un script de "nom de fichier", la fonction appelée sera "isValidFileName" et adoptera le nom et l'emplacement des fichiers dans les paramètres.
· Si le script est un script de "contenant texte", la fonction appelée sera "isValidLine" et adoptera le numéro de la ligne et le texte dans les paramètres.

Les scripts sont seulement appelés si les autres critères de recherche sont satisfaits (nom ou expressions contenues dans le texte). Les fonctions doivent retourner une valeur booléenne vraie ou fausse pour indiquer si le fichier ou la ligne est valide ou non.

Exemples :

Note : Veuillez ouvrir le sous-dossier "Sample Scripts" dans le dossier d'installation principal de FileLocator Pro pour visualiser quelques exemples de scripts.

Script lecture seule

L'exemple suivant montre un échantillon d'un script de nom de fichier qui limite les fichiers relevés à ceux qui sont en lecture seule. Note : d'autres attributs peuvent être utilisés, par exemple utiliser "32" au lieu de "1" pour trouver des fichiers archivés.

var objFSO = new ActiveXObject( "Scripting.FileSystemObject" );

function isValidFileName( strPath, strFileName )

{

var bIsValid = false;

try

{

var objFile = objFSO.GetFile( strPath + strFileName );

bIsValid = ( objFile.Attributes & 1 );

}

catch( e )        {}

return bIsValid;

}

Notez que les blocs try...catch ont été utilisés pour éviter que les exceptions ne soient relancées dans le moteur de recherche. Si une exception est trouvée et n'est pas attrapée par le script, la recherche s'arrêtera.

Script dossiers seulement

Un autre exemple montre comment localiser seulement les dossiers.

var objFSO = new ActiveXObject( "Scripting.FileSystemObject" );

function isValidFileName( strPath, strFileName )

{

var bIsValid = false;

try

{

bIsValid = objFSO.FolderExists( strPath + strFileName );

}

catch( e )        {}

return bIsValid;

}

Script d'expression NOT

Voici un exemple de comment mettre en place un NOT lors d'une recherche de contenus en utilisant le moteur de recherche JScript (l'expression NOT à trouver est entrée dans le champ "contenant texte" de l'onglet Scripting) :

// An example of a NOT expression, this time using JScript's built in Regular Expression object.

var regExp = new RegExp( SearchParms.ContainingTextCustomParm );

function isValidLine( nLineNum, strText )

{

var bIsValid = true;

try

{

bIsValid = !regExp.test( strText );

}

catch( e )        {}

return bIsValid;

}

Notez comment l'objet d'expressions rationnelles est créé à l'extérieur du corps de fonction afin qu'il soit seulement créé puis compilé une fois par recherche, bien qu'il soit possible de le mettre en place plusieurs fois.

Exclure des répertoires

Une autre variation de l'expression NOT (voir ci-dessous) est pour exclurez certains répertoires de la recherche. Par exemple, pour exclure le répertoire Windows d'une recherche, l'expression NOT sera associée à 'C:\\Windows'. Voici une exemple de la mise en place d'un NOT pour un emplacement (l'expression NOT à trouver est entrée dans le champ "nom de fichier" dans l'onglet Scripting) :

var regExp = new RegExp( SearchParms.FilenameCustomParm );

function isValidFileName( strPath, strFileName )

{

var bIsValid = true;

try

{

bIsValid = !regExp.test( strPath );

}

catch( e )        {}

return bIsValid;

}

Notez l'utilisation de deux "\\" pour représenter un seul "\" dans 'C:\\Windows' puisque le slash est le caractère d'échappement utilisé dans les expressions rationnelles.

Objet des paramètres de recherche

Les scripts peuvent accéder à presque n'importe quel autre critère de recherche dans l'objet 'SearchParms". Par exemple, le script isValidFileName pourrait utiliser une valeur personnalisée de SearchParms entrée dans l'onglet Scripting comme ceci :

var strCustom = SearchParms.FilenameCustomParm;

SearchParms donne accès aux critères suivants :

CurrentFileName (Fil) - Nom de fichier actuellement traité.

CurrentFilePath (Fil) - Chemin du fichier actuellement traité.

ContainingText (Fil) - Valeur entrée dans le champ "contenant texte".

ContainingTextCustomParm (Fil ) - Valeur entrée dans le champ "paramètre personnalisé" pour un script contenant du texte.

ContainingTextRegExp (Booléenne) - Indique si l'expression rationnelle du texte contenu a été désactivée.

EOLUnix (Booléenne) - Indique si l'option EOL Unix a été activée.

EOLMac (Booléenne) - Indique si l'option EOL Mac a été activée.

Filename (Fil) - Valeur entrée dans le champ "nom de fichier".

FilenameCustomParm (Fil) - Valeur entrée dans le champ "paramètres personnalisés" pour le script de nom de fichier.

FilenameExcludeExp (Booléenne) - Indique si "l'expression NOT spécifiée" a été activée.

FilenameRegExp (Booléenne) - Indique si l'expression du nom de fichier a été activée.

LookIn (Fil) - Valeur entrée dans le champ "regarder dans".

MatchFilenameCase (Booléenne) - Indique si l'option de respect de la casse a été activée.

MatchContentsCase (Booléenne) - Indique si l'option de respect de la casse pour le texte contenu a été activée.

ModifiedAfter (Date) - Valeur entrée dans le champ "modifié après".

ModifiedBefore (Date) - Valeur entrée dans le champ "modifié avant".

SearchContents (Booléenne) - Indique si la recherche se fait dans le contenu des fichiers.

SearchOnePhase (Booléenne) - Indique si la "recherche en une phase" a été activée.

SearchSubFolders (Booléenne) - Indique si la "recherche dans les sous-dossiers" a été activée.

SizeMoreThan (Entier) - Valeur entrée dans le champ "taille supérieure à".

SizeLessThan (Entier) - Valeur entrée dans le champ "taille inférieure à".


Look In

Regarder dans

Souvent, le champ Regarder dans spécifie simplement un dossier dans lequel lancer une recherche. Toutefois, ce champ peut accepter beaucoup plus qu'un seul emplacement de dossier.

Types de valeurs acceptées dans le champ Regarder dans :

Dossier simple

ex. c:\work\doc

Expression

Expressions qui peuvent être spécifiées pour des parties individuelles du l'emplacement. L'expression ne s'applique pas sur le chemin mais seulement sur une partie. Par exemple l'expression rationnelle

c:\usr\dev\.*\release

trouvera tous les dossiers nommés 'release" deux niveaux plus bas que le dossier "c:\usr\dev".

Fichier simple

ex. c:\work\doc\file.txt

Plusieurs fichiers / dossiers

Plusieurs entrées séparées par un point virgule, par ex.

c:\work\doc;c:\work\email;c:\work\logs\special.log

Exclure des fichiers / dossiers

Une localisation exclue identifiée par un point d'exclamation, par ex, pour exclure le sous-dossier "audit" :

c:\work\doc;!c\work\doc\audit

Filtres de localisation

Les filtres sont des expressions appliquées sur le dossier pour chaque critère de recherche pour permettre à des groupes d'éléments d'être facilement visés. Un filtre commence par un signe plus ou moins. Par ex, pour exclure tous les sous-dossiers de source Subvention (nommés '.svn') :

c:\work\source;-.svn

ou, pour inclure seuls les sous-dossiers de comptabilité tout en excluant les sous-dossiers de subventions :

c:\work\source;+account;-.svn

Liste de choix

Une liste de choix est une liste d'endroits dans lesquels recherchez, chaque nouveau étant noté sur une nouvelle ligne, recherchées depuis un fichier externe. Une liste de choix est identifiée par un signe égal, par ex. :

=c:\lookup\accountsource.txt

et les contenus du fichier accountsource.txt file pourrait ressembler à :

c:\work\source

c:\work\tools

+account

-.svn

Macros

Les macros identifient les localisations communes sur une machine Windows. Les macros sont évaluées pour le système hôte à chaque fois que la recherche est lancée, ce qui est pratique si on crée des critères de recherche sur différentes machines.

$(AdministrativeTools)

$(AllLocalDrives)

$(ApplicationData)

$(ApplicationDataDrive)

$(CommonAdminTools)

$(CommonApplicationData)

$(CommonDesktopFolder)

$(CommonDocuments)

$(CommonDocumentTemplates)

$(CommonFavourites)

$(CommonMyMusic)

$(CommonMyPictures)

$(CommonMyVideo)

$(CommonProgramFiles)

$(CommonProgramsGroup)

$(CommonStartMenu)

$(CommonStartup)

$(DesktopFolder)

$(DocumentTemplates)

$(Favourites)

$(Fonts)

$(InternetCache)

$(InternetCookies)

$(InternetHistory)

$(LocalApplicationData)

$(MyDocuments)

$(MyDocumentsDrive)

$(MyMusic)

$(MyNetwork)

$(MyPictures)

$(MyPrinters)

$(MyVideo)

$(Profile)

$(ProgramFiles)

$(ProgramsGroup)

$(Recent)

$(SendTo)

$(StartMenu)

$(Startup)

$(SystemFolder)

$(WindowsFolder)

$(WindowsInstallDrive)

Variables d'environnement

Chaque variable d'environnement mise en place pour l'ordinateur / l'application peut être utilisé dans le champ Regarder dans, par ex. :

%TEMP%;%CLASSPATH%

pourrait être utilisé pour rechercher tous les dossiers indiqués par les variables d'environnement TEMP et CLASSPATH mises en place pour l'ordinateur.

Filtres de recherche persistante

Lorsqu'un filtre est si commun qu'il devrait être utilisé pour chaque recherche, comme pour exclure des fichiers de métadonnées avec code source, il peut être configuré comme un filtre de recherche persistante.

Une filtre de recherche persistante peut être n'importe quelle valeur valide du champ Regarder. Pour plus d'informations, visitez la page des filtres de recherche persistents.


Filtres de recherche persistante

Les filtres de localisation sont souvent utilisés pour inclure ou exclure certains endroits de recherche pour une recherche donnée. Certains filtres sont si communs qu'ils sont mis en place pour toutes les recherches, par exemple exclure les fichiers de métadonnées avec code source. Les filtres de rechercher persistante permettent la définition de ces filtres communs qui (lorsqu'activés) sont appliqués à toutes les recherches.

Lorsqu'un filtre de recherche persistante ou plus est actif, une encoche rouge est affichée sur le bouton de filtre :

Cliquer sur le bouton de filtre ouvre la fenêtre de filtres de recherche persistantes, montrant la liste des filtres et leurs statuts :

Pour changer un filtre, double-cliquez sur le filtre, et pour en ajouter un nouveau, cliquez sur le bouton "ajouter...".

Un filtre de recherche est normalement un filtre de localisation, comme -archive, mais peut en fait être n'importe quelle valeur Regarder dans. Plusieurs valeurs peuvent être séparées par des points virgules, par ex :

-.svn;-archive

Tous les filtres de recherche actifs sont annexés aux valeurs du champ "Regarder dans" au moment de la recherche.


Prise en charge Unicode

Prise en charge des fichiers système unicodes

FileLocator Pro est conçu avec les bibliothèques d'unicodes de Windows, c'est pourquoi il prend en charge la recherche des fichiers système unicodes.

Prise en charge de la recherche de contenu unicode

La recherche de contenu dans les fichiers traités par des extensions (comme IFilters) prend en charge la recherche unicode si le format sélectionné prend en charge l'unicode.

La recherche de fichiers texte prend en charge l'unicode si le fichier peut être identifié comme unicode, soit par un marqueur d'ordre des octets (MOO) ou une déclaration d'encodage XML au début d'un fichier XML. Les types d'unicodes pris en charge sont UTF-16LE, UTF-16BE, et UTF-8.

La recherche binaire de types de fichiers non identifiables, comme les EXE etc., est lancée en utilisant une recherche ASCII à moins que cela soit spécifié autrement dans les paramètres de format par défaut UTF-8.


Rechercher dans la recherche

Parfois, il est préféracle de limiter les recherches subséquentes à la liste de résultats ou à une partie de la liste. FileLocator Pro prend en charge la recherche d'une partie des fichiers via deux options :

Fichier - Liste de résultats de recherche | Recherche tous les fichiers qui sont dans la liste de résultats.
Fichier - Recherche dans la sélection actuelle | Recherche tous les fichiers qui sont actuellement sélectionnés dans la liste de résultats.

Rechercher dans les recherches fonctionne en créant une nouvelle recherche et en pré-remplissant le champ "regarder dans" avec tous les fichiers à fouiller.


Recherche d'archive outlook PST

FileLocator Pro est capable de recherche dans toutes les archives PST, du plus ancien outlook 97 jusqu'à la version la plus récente. De plus, puisque FileLocator Pro "comprend" le format de fichier sous-entendu, vous n'avez pas besoin d'installer outlook et vous pourrez également outrepasser les mots de passer et le cryptage présents sur certains fichiers PST. Toutefois, puisque FileLocator Pro n'est pas dédié à la recherche de fichiers PST, la procédure peut paraître assez déroutante. Vous serez sûrement tenté d'utiliser le champ de nom de fichier pour identifier une archive PST, par ex. *.pst, plutôt que l'objet que vous recherchez dans l'archive, comme un courriel.

FileLocator Pro traite basiquement chaque élément outlook individuel, comme un courriel, un contact, une calendrier, etc., dans un fichier PST en tant que fichier séparé. Le "nom de fichier" pour chaque élément est dépendant du type d'élément, par exemple pour les courriels, le sujet sera utilisé comme nom de fichier. Pour recherche un fichier PST, suivez ces étapes :

1. Spécifiez la localisation des fichiers PST (ou d'un fichier PST) dans le champ "regarder dans"

La localisation peut inclure des dossiers.

2. Basculez vers la recherche PST dans l'onglet "options"

Sans basculer vers cette option, l'archive PST sera traitée comme un fichier normal et sera simplement fouillé en utilisant son contenu binaire. Si l'option "rechercher dans les pièces-jointes" est cochée, les pièces-jointes de chaque courriel seront également fouillées, sinon, seul le texte du courriel le sera.

3. Utilisez le champ "nom de fichier" pour rechercher par sujet, et "contenant texte" pour rechercher par contenu

Chaque résultat sera affiché en tant que fichier texte, qui pourra être copié ou déplacé vers un autre endroits. Les résultats peuvent également être exploités en utilisant le visionneur interne, tout comme pour les résultats normaux.

Rechercher dans plusieurs fichiers PST

Les exemples ci-dessus montrent comment rechercher dans un seul fichier PST, mais FileLocator Pro peut rechercher dans plusieurs fichiers en une seule recherche. Au lieu de spécifier un seul fichier PST dans le champ "regarder dans", spécifiez simplement le dossier (ou la racine de la sous-arborescence) où les fichiers PST sont localisés. Pour s'assurer que seuls les fichiers PST soient recherchés, ajoutez le filtre de localisation +.pst, par ex. :

C:\Folder\Email;+.pst

Pour exporter le courriel et / ou la pièce jointe pour séparer les fichiers, copiez / collez simplement ou faites glisser le fichier vers un endroit dans Explorer.


Recherche de fichier MSG

La recherche de fichier MSG est activée dans l'onglet "options".

Lorsqu'elle est activée, FileLocator Pro traite les fichiers MSG comme des contenants d'autres fichiers (le fichiers MSG deviennent des "dossiers" virtuels). Le corps du courriel est traité comme un seul fichier .txt et chacunes des pièces jointes en tant que fichiers séparés (en assumant que l'option "rechercher dans les pièces jointes" ait bien été cochée). De plus, lors d'une recherche de fichiers MSG, il est important d'éviter de spécifier le nom de fichier *.msg puisque peu de courriels contiendront *.msg dans leur sujet. Au lieu de cela, utilisez les filtres de localisation pour restreindre la recherche aux fichiers MSG seulement, par ex. :

C:\Folder\Emails\;+.msg

Pour exporter le courriel et / ou les pièces jointes pour séparer les fichiers, copiez / collez simplement ou faites glisser les fichiers vers un endroit dans Explorer.

Exemple 1 : Rechercher des fichiers MSG par sujet et contenus

L'exemple ci-dessous montre comment le champ "nom de fichier" est utilisé pour rechercher le sujet du courriel, alors que le champ "contenant texte" est utilisé pour rechercher dans le corps du courriel. Notez que le champ "nom de fichier" a été basculé vers une recherche booléenne pour que la recherche soit plus flexible.

Exemple 2 : Rechercher des fichiers MSG pour trouver des images en pièces jointes

Cet exemple utilise le champ "nom de fichier" pour rechercher des pièces jointes qui sont soit en PNG, soit en JPG, soit en BMP.

Important : Assurez-vous que l'option "rechercher dans les pièces jointes" ait bien été cochée dans l'onglet options.


Exporter les résultats

Pour l'exportation des résultats FileLocator Pro offre à la fois la fonctionnalité Rapports et l'option de menu Fichier -> Exporter les Résultats. La fenêtre d'exportation des résultats permettra aux résultats d'être sauvegardés soit dans le presse-papiers, soit dans un fichier spécifique.

Les résultats peuvent être sauvegardés sous plusieurs formats :

Séparés par des virgules (CSV) | Tableau de résultats séparés par une virgule (format privilégié pour sauvegarder des résultats à ouvrir dans Excel).
HTML | Résultats formatés en HTML, conçus pour ressembler aux résultats affichés dans l'onglet Résultats.
Séparés par des tabulations | Pour les recherches de contenus, l'information est groupée par fichier, comme dans l'onglet Résultats. La tabulation (ASCII 09) est utilisée pour séparer les valeurs.
Séparés par des tabulations (tableur) | Tableau de résultats séparés par des tabulations, similaire à un CSV, mais utilisant une tabulation (ASCII 09) pour séparer les colonnes (le meilleur format pour la sauvegarde vers le presse-papiers puis le collage dans Excel).
Texte | Format de texte conçu pour ressembler à l'onglet Résultats.
XML | Résultats formatés en XML.

Formatage personnalisé

Pour le formatage avancé, XLS transforms peut être utilisé pour personnaliser le format de sortie. XLS transforms sont des langues basées sur le texte qui définissent les transformations de données et qui peuvent être utilisées pour convertir les données XML de FileLocator Pro vers le format désiré. Des exemples de transforms sont incluses dans le dossier Sample Transforms, et incluent :

Contents_NoLineNumbers.xsl

Exporte seulement les contenus trouvés, sans aucune information, comme des fichiers de données ou des numéros de ligne.

FileName_Only.xsl

Exporte seulement le nom de fichier sans informations de localisation, chaque fichier étant exporté sur une ligne différente.

FullName_FileSizeBytes.xsl

Exporte le nom de fichier complet (avec sa localisation) ainsi que sa taille en bytes.

Hash_Separated.xsl

Exporte les informations du nom de fichier, séparées par des "#".

Hits_Only.xsl

Exporte seulement les résultats de la recherche, sans aucune information de fichier ni de texte. Pratique pour les recherches d'expressions communes qui mettent en avant du texte qui correspondent à l'expression données, comme des numéros de téléphone ou des adresses e-mail. Ce transforms diffère du Unique_Hits_Only.xsl dans le fait qu'il donnera tous les résultats trouvés dans le texte, et donnera également les résultats dupliqués.

HTMLTransform.xsl

Exporte les données dans un format similaire à l'exportation HTML standard.

Unique_Hits_Only.xsl

Exporte seulement les résultats de la recherche, sans aucune information de fichier ni de texte. Pratique pour les recherches d'expressions communes qui mettent en avant du texte qui correspondent à l'expression données, comme des numéros de téléphone ou des adresses e-mail. Ce transforms diffère du Hits_Only.xsl dans le fait qu'il donne seulement les résultats une fois, et qu'il ne donnera qu'une fois les résultats dupliqués, peu importe le nombre de fois où on les trouve dans le document.

xcopy.xsl

Génère des déclarations XCOPY pour copier d'un dossier vers un autre.

Pour chaque fichier, une commande XCOPY est générée, avec seulement sa lettre de lecteur remplacée dans le chemin d'accès source, par ex :

C:\folder1\folder2\filename1.txt

génère :

xcopy "C:\folder1\folder2\filename1.txt" "E:\folder1\folder2\*"

NOTE : Le fichier XSL doit être édité pour changer sa cible de E: vers le dossier désiré. Ne fonctionne pas avec les chemins d'accès UNC, par ex. \\server1\folder1\folder2


Wizards

Assistants

Pour aider l'utilisateur avec certaines caractéristiques complexes de FileLocator Pro, deux assistants sont disponibles :

· Assistant de recherche (Interface basique seulement)
· Assistant d'expressions (Interface avancée seulement)


Assistant de recherche

L'assistant de recherche guide l'utilisateur pour entrer les critères de recherche basiques, avec des exemples et des conseils.

Il présente à l'utilisateur trois pages, en lui demandant les informations suivantes :

· Nom du fichier.
· Contenus du fichier.
· Localisation du fichier.

Sur la page finale, si la case "commencer automatiquement la recherche" est cochée, la recherche commencera lorsque l'utilisateur cliquer sur "terminer".


Assistant d'expressions (Ass d'Exp.)

L'assistant d'expressions guide l'utilisateur pour créer une expression rationnelle basique. L'assistant d'expressions peut être utilisé pour créer des expressions de recherche pour un nom de fichier ou des contenus.

Note : Le terme "fil" est utilisé comme un terme générique référant soit au nom de fichier, soit à son contenu. Basiquement, un fil est n'importe quel mot ou groupe de mots qui représente exactement un nom de fichier.

Première page (Présentation de l'assistant)

La première page de l'assistant est simplement une présentation de l'assistant avec des notes pour le type d'expression en cours de création (une note pour le nom du fichier et une autre note pour le contenu).

Deuxième page (Création de l'expression)

La deuxième page est l'endroit où vous allez travailler. Elle ressemble à quelque chose comme ceci :

Ci-dessus, un exemple d'expression pour un nom de fichier est affiché, et il trouvera tous les noms de fichiers qui incluent la phrase "MyFile" suivie par n'importe quel caractère, suivi par un chiffre, et se terminant par .txt (fichier texte). L'assistant trouvera alors tous les fichiers comme 'Dave_MyFile54.txt' ou 'MyFile_Num2.txt' mais pas 'MyFile.txt', 'A_MyFile34a.txt', ni 'MyFile34.doc'.

Si vous pensez à la manière dont les expressions rationnelles fonctionnent, le fonctionnement de l'assistant devrait vous paraître plus évident. Une expression rationnelle est construite sur un nombre d'entrées. Il y a une entrée de départ, plusieurs entrées pour le corps, et une entrée finale. Chaque entrée a un type spécifique :

· Inconnu. La valeur entrée est inconnue, par ex. le début d'un nom de fichier peut être inconnu.
· Tout caractère. Trouve un caractère seul.
· Un caractère. Trouve un caractère spécifique entré dans le champ "texte".
· N'importe lequel de ces caractères. Trouve n'importe quel caractère entré dans le champ "texte".
· Tout caractère sauf ceux-ci. Trouve tous les caractères sauf ceux entrés dans le champ "texte".
· La phrase. Trouve une phrase spécifique entrée dans le champ "texte".
· Espace(s). Trouve un espace.
· Tout caractère numérique. Trouve tous les caractères numériques, de 0 à 9.
· Tout caractère texte. Trouve tous les caractères alphabétiques, de A à Z.

Une fois que l'utilisateur a spécifié un type d'entrée et le texte, si demandé par le type d'entrée, il doit ensuite spécifier le nombre de fois où l'occurrence apparaît :

· Zéro ou une fois. Le type d'entrée peut ou peut ne pas être là, mais s'il l'est, il ne l'est pas plus d'une fois.
· Zéro ou plusieurs fois. Le type d'entrée peut ou peut ne pas être là, mais s'il l'est, il l'est au moins une fois.
· Une fois seulement. Le type d'entrée doit être présent une fois seulement.
· Une fois ou plus. Le type d'entrée doit être présent au moins une fois.

L'assistant d'expressions ne fournit pas vraiment toutes les fonctionnalités pour les expressions rationnelles. Toutefois, si l'utilisteut sait comment construire ses propres expressions rationnelles, il peut entrer tout ou partie d'une expression rationnelle en ajoutant une entrée du type "la phrase" et en mettant l'expression rationnelle dans le champ "texte".

Les entrées peuvent être réarrangées en utilisant le glisser / déposer.

Troisième page (Attention : Caractères spéciaux entrés)

Lorsque l'utilisateur a terminé d'entrer l'expression rationnelle, l'utilisateur peut normalement cliquez sur "terminer" pour que l'expression entrée aille se déposer dans la fenêtre de recherche principale. Toutefois, si l'utilisateur a entré des caractères spéciaux (caractères qui ont une signification spécifique dans les expressions rationnelles) dans le champ "texte" de toute entrée, le bouton "terminer" se transformera en bouton 'suivant" et l'utilisateur sera informé de l'entrée de caractères spéciaux. L'utilisateur aura alors deux choix, soit de demander à FileLocator Pro de convertir les caractères spéciaux afin qu'ils ne soient pas traités comme des caractères spéciaux (par défaut), soit de laisser l'expression comme elle est puisque l'utilisateur les a entrés en toute connaissance de cause.

Dans la capture d'écran ci dessous, vous pouvez voir ce qui s'est passé avec un exemple. Le "." dans ".txt" est le caractère générique c'est pourquoi au lieu d'avoir un bouton "terminer" il y a un bouton "suivant". Si vous regardez l'expression résultante, vous verrez que le "." a été précédé d'un caractère d'échappement "\". Cela s'est fait automatiquement puisque l'action par défaut, qui est de convertir les caractères spéciaux afin qu'ils ne soient pas traités comme des caractères spéciaux. Cette page (la troisième) permet à l'utilisateur de désactiver cette action.


Expressions rationnelles

FileLocator Pro fournit une prise en charge étendue des expressions rationnelles, en utilisant une syntaxe compatible avec Perl ou une syntaxe classique.

Syntaxe compatible Perl

La syntaxe d'expressions rationnelles compatibles avec Perl est basée sur le moteur d'expressions rationnelles Boost, et inclut non seulement les fonctions des "expressions classiques" mais aussi les expressions de style Perl, détaillées ici :

http://www.boost.org/doc/libs/1_51_0/libs/regex/doc/html/boost_regex/syntax/perl_syntax.html

Syntaxe classique

La syntaxe d'expressions rationnelles classique de FileLocator Pro prend en charge les éléments classiques d'expressions rationnelles, qui seront le sujet de cette section. Pour continuer, cliquez sur la section démarrage rapide .


Démarrage rapide

FileLocator Pro inclut un moteur d'expressions rationnelles comme l'un de ses types d'expressions. Les expressions rationnelles (parfois surnommées exprat) fournissent une langue concise pour décrire quoi chercher exactement. En des termes plus basiques, vous pouvez séparer les expressions en deux parties :

- ce que vous recherchez

- le nombre d'occurrences que vous souhaitez trouver

Prenons un exemple :

1. Je veux trouver tous les fichiers nommés abc, abbc, abbbc, abbbbc, etc. Donc je souhaite trouver tous les fichiers qui commencent avec un "a", suivi d'un ou plusieurs "b", suivi d'un "c". L'expression sera :

ab+c

En désagrégeant cette expression, nous lisons :

- trouver une occurrence de "a"

- trouver au moins une occurrence de "b" (le "+" indique "un ou plus")

- trouver une occurrence de "c"

Les caractères qui spécifient le nombre d'occurrences sont :

+ un ou plus

* zéro ou plus

? zéro ou un

Alors ab?c trouvera tous les fichiers nommés abc ou ac (il peut y avoir zéro ou un "b").

Un caractère d'expression rationnelle très important est le point "." (caractère générique) puisqu'il trouve TOUS les caractères. Alors a.c trouvera aac, abc, acc, adc, aec, afc, a1c, a6c, etc. Et si nous combinons cela avec un caractère d'occurrence, nous pouvons commencer à produire quelques expressions pratiques :

dave.*vest

qui se lit :

- trouver une occurrence de "d"

- puis une occurrence de "a"

- puis une occurrence de "v"

- puis une occurrence de "e"

- puis zéro ou plus d'occurrence de n'importe quel caractère

- puis une occurrence de "v"

- puis une occurrence de "e"

- puis une occurrence de "s"

- puis une occurrence de "t"

et trouvera alors 'davevest', 'dave vest', 'dave is wearing a vest'.

D'autres caractères d'expressions rationnelles et conseils peuvent être trouvés sur les pages suivantes. Plus de détails sur les expressions rationnelles.


Qu'est-ce qu'une expression rationnelle ?

Une expression rationnelle est un moyen pour décrire un groupe de mots (un "fil"). Elle permet à un utilisateur de bâtir un ensemble de règles complexes pour décrire exactement quelles caractéristiques doit avoir le fil. Alors que cette documentation utilise un fil de mots, vous pouvez penser à un fil comme un nom de fichier (lorsque vous recherchez un nom de fichier en utilisant les expressions rationnelles), ou à un texte dans un document (lorsque vous utilisez une expression rationnelle pour rechercher dans des contenus).

L'expression rationnelle la plus simple est une séquence de lettres, de nombres, ou des deux. Une telle expression rationnelle trouvera tous les fils qui contiennent cette séquence. Par exemple :

L'expression rationnelle "foo" trouve tous les fils contenant "foo". Donc si vous souhaitiez trouver un fichier avec les lettres "fred", l'expression rationnelle devra être simplement "fred".

Ceci est bien évidemment un exemple simple, mais vous pouvez aussi bien mettre en place des règles plus compliquées. Par exemple :

Pour trouver un fichier qui commence par "July" ou "August", suivi à un moment donné de "Document" ou "Document", puis suivi à un moment donné par un chiffre, et dont l'extension est en ".doc", l'expression devra être : '^(July|August).*Documents?.*[0-9]+.*\.doc$'

Cette expression trouvera :

· JulysPrivDocuments_23.doc
· August Documents Num5a.doc
· etc.

Ne vous inquiétez pas si l'expression ci-dessus vous paraît compliquée, c'est normal. C'est pourquoi FileLocator Pro inclut un assistant d'expressions qui vous guidera à travers les étapes nécessaires pour créer vos propres expressions rationnelles en utilisant des termes anglais communs.

Pour plus d'informations, veuillez lire les bases pour les expressions rationnelles.

Note : Vous pouvez tester votre expression dans le moteur de FileLocator Pro en utilisant "outils" -> "testeur d'expressions rationnelles...".


Bases des expressions rationnelles

Les expressions rationnelles utilisent des caratères spéciaux (également nommés "opérateur d'expressions rationnelles") pour spécifier les règles pour les fils. Voici un résumé de ces caractères :

^ Début d'un fil

$ Fin d'un fil

. Tout caractère

[ Début d'une liste de caractères

] Fin d'une liste de caractères

( Début d'un groupe d'expressions

) Fin d'un groupe d'expressions

| Deux expressions OR

\ Caractère d'échappement

* L'expression précédente arrive zéro ou plus de fois

? L'expression précédente arrive zéro ou une fois

+ L'expression précédente arrive une ou plusieurs fois


*, ?, + (caractères d'occurrence)

Spécifie le nombre d'occurrences du caractère ou du groupe précédent. Dans un expression rationnelle, il y a quatre choix possibles lorsque l'on essaye de spécifier combien d'occurrences l'expression rationnelle devrait trouver :

Zéro ou une, le caractère "?"

Zéro ou plusieurs, le caractère "*"

Une ou plusieurs, le caractère "+"

Une seule, le caractère seul (sans aucun caractère d'occurrence).

Par exemple :

Si vous avez entré le nom de fichier sous forme 'complaint ?doc' il trouvera tous les fichiers qui contiennent le mot 'complaint' suivi de zéro ou un espace, suivi de 'doc'. Il trouvera alors le fichiers comme 'my complaint doc.doc' et 'mycomplaintdoc.txt', mais PAS les fichiers 'my complaint_doc.doc' ni 'my complaints doc.doc'.

Si vous avez entré le nom de fichier sous forme '^my.*doc$' il trouvera tous les fichiers qui commencent avec le mot 'my' suivi de zéro caractères ou plus, et terminant par 'doc' (notez l'utilisation des caractères spéciaux '^' départ d'un fil, '.' tout caractère, et '$' fin d'un fil). C'est pourquoi il trouvera tous les fichiers comme 'my_note.doc', 'my_owndoc', et 'my_specialfile.doc' mais PAS les fichiers 'my_note.txt' ni 'thisis_my_note.doc'.

Si vous avez entré le nom de fichier sous forme '_file[0-9]+' il trouvera tous les fichiers qui contiennent le mot '_file' suivi d'un ou plusieurs chiffres (notez l'utilisation des caractères spéciaux '[' et ']' liste de caractère). C'est pourquoi il trouvera tous les fichiers comme 'my_file245.doc' et 'the_file0023.txt' mais PAS les fichiers 'a_file_34.txt' ni 'some_file 009.txt'.


\ (caractère d'échappement)

Le caractère d'échappement est utilisé pour supprimer la signification spéciale d'un caractère spécial.

Par exemple :

L'expression 'Cost$' trouvera un fil se terminant par 'Cost' alors que l'expression 'Cost\$' trouvera un fil contenant 'Cost$'. Comme vous pouvez le voir, le caractère d'échappement a enlevé la signification spéciale du caractère '$' fin du fil.

L'expression 'file.txt' trouvera un fil qui contient 'file' suivi de n'importe quel caractère et suivi par 'txt', alors que l'expression 'file\.txt' trouvera un fil qui contient 'file.txt'. Cette fois le caractère d'échappement a enlevé la signification spécial du caractère '.' tout caractère.

Finalement, l'expression pour rechercher le caractère '\' est précédée de '\', supprimant le caractère d'échappement. Pour rechercher '3\4' utilisez l'expression '3\\4'.


| (expression OR)

Utilisez | lorsqu'une expression ou une autre peut être utilisée.

Par exemple :

Les deux expression '(stabilised|stabilized) condition' et 'stabili(z|s)ed condition' trouveront 'stabilised condition' et 'stabilized condition'.

'(1|2|3) (person|people)' trouvera '1 person' et '2 people' et '3 people' mais ne trouvera pas '4 people' (il trouvera également '2 person' etc.). Note : cette expression pourrait également être exprimée en utilisant une liste de caractères.


(...) (groupe d'expression)

Les parenthèses sont utilisées pour grouper des expressions rationnelles de manière arithmétique. Elles sont généralement utilisées avec la fonctionnalité '|' OR pour grouper des alternatives.

Par exemple :

L'expression '12 Mar(ch)? 2000' trouvera le fil '12 March 2000' et '12 Mar 2000'. Notez l'utilisation du '?' caractère d'occurrence zéro ou plus

Si vous avec entré le nom de fichier comme '^myfile\.(txt|doc)$' il trouvera tous les fichiers dont le nom était 'myfile.txt' ou 'myfile.doc'. Notez l'utilisation du caractère '^' début du fil, du '\' caractère d'échappement pour traiter le "." dans ".txt" littéralement ,et le caractère '$' fin du fil.


[...] (listes de caractères)

Spécifie une liste de caractères qui sont valides dans le fil. Les caractères peuvent être listés individuellement ou une gamme de caractères peut être indiquée en donnant deux caractères et en les séparant par un '-'. Par exemple,'[abc]' trouvera tous les caractères 'a', 'b', ou 'c'; c'est pareil que '[a-c]', qui utilise une gamme pour exprimer la même gamme de caractères.

Vous pouvez ajouter des caractères qui ne sont pas dans la gamme en en ajoutant dans le set. Ceci sera indiqué avec un '^' comme premier caractère dans la liste (note : ceci est le même caractère que ceux qui commencent un fil). Par exemple, '[^5]' trouvera tous les caractères sauf '5'.

Des gammes multiples sont autorisées. Par ex. la liste '[A-Z0-9]' est un moyen commun pour exprimer l'idée de "tous les caractères alphanumérique". Pour inclure un des caractères `\', `]', `-' ou `^' dans une liste de caractères, utilisez le '\' caractère d'espacement.

Par exemple :

L'expression '[0-9]+' trouvera tous les chiffres dans un fil (notez l'utilisation du '+' caractère d'occurrence).

L'expression '[0-9]+/[0-9]+/[0-9]+' est une expression qui pourrait être utilisée pour rechercher des dates dans un fil. Bien que cela ne vérifie pas la validié de la date, il sera rare qu'il trouve un autre fil qui corresponde à cette suite.


. (caractère générique)

Trouve tous les caractères simple. Il est utilisé pour spécifier une portion inconnue dans le fil. Puisque le point est utilisé dans presque tous les noms de fichiers Windows, il est très commun d'oublier qu'il a une signification spéciale dans les expressions rationnelles. Si l'utilisateur souhaite utiliser littéralement le point dans une recherche, il devra être précédé du '\' caractère d'échappement. Par exemple :

Si vous avez entré le nom de fichier 'mydoc.doc' cela trouvera tous les fichiers contenant 'mydoc' suivi de n'importe quel caractère, suivi de 'doc'. C'est pourquoi, même s'il trouvera 'mydoc.doc' il trouvera également 'mydoc1doc' et 'mydocXdoc'. Si vous souhaitiez chercher simplement 'mydoc.doc' l'expression sera 'mydoc\.doc'.

Exemple :

Si vous avez entré le nom de fichier '^mydocument..\.txt$' il trouvera tous les fichiers qui commencent par 'mydocument' suivi d'exactement deux caractères, et terminant par '.txt' (notez l'utilisation du caractère de '^' début de fil, et du '\' caractère d'espacement pour traiter le '.' dans '.txt' littéralement, et le caractère '$' fin du fil). Il trouvera donc les fichiers comme 'mydocument_1.txt' et 'mydocument1a.txt' mais pas 'mydocument.txt' ni 'mydocument_1a.txt'.

L'expression 'my.*\.txt' trouvera tous les fichiers qui incluent 'my' suivi d'un nombre de caractères, suivi de '.txt' (notez l'utilisation d'une '*' pour spécifier zéro occurrence ou plus). Il trouvera donc les fichiers comme 'my_examples.txt' et 'this is my file.txt.doc' mais pas 'myfile.doc' ni 'm_y_file.txt'.


$ (fin du fil)

Trouve la fin d'un fil (pour trouver le début d'un fil, utiliser '^').

Par exemple :

Si vous avez entré le nom de fichier 'complaint\.doc$' il trouvera tous les fichiers qui se terminent par 'complaint.doc' (notez l'utilisation du '\' caractère d'échappement pour le '.'). Il trouvera donc les fichiers comme 'bank_complaint.doc' et 'my_complaint.doc' mais pas 'some_complaint.txt' ni 'some_complaint_2.doc'.


^ (début du fil)

Trouvera le début d'un fil (pour trouver la fin d'un fil, utiliser '$').

Par exemple :

Si vous avez entré le nom de fichier '^win' il trouvera tous les fichiers qui commencent par 'win'. Il trouvera alors les fichiers 'winhelp.exe' et 'windows_questions.txt' mais pas 'Copy of winhelp.exe' ni 'some_winfile.txt.


Autres exemple

 Top Previous

AND

Bien que le moteur d'expressions rationnelles ne prenne pas directement en charge l'expression booléenne AND, il peut, de manière limitée, la simuler. Par ex. :

Pour rechercher une ligne contenant 'error' AND 'log' l'expression devra être '(error.*log)|(log.*error)'. Basiquement, les différentes combinaisons possibles ont été combinées pour trouver 'error' suivi de 'log' OU trouver 'log' suivi de 'error'. Alors que cela fonctionne pour une petite quantité de mots, cela devient vite infaisable avec un nombre de mots plus important.

Bien évidemment, la manière la plus facile de spécifier une expression de style AND est d'utiliser le moteur d'expressions booléennes.