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1 Introduction

Welcome to FileLocator Pro

FileLocator Pro is the award winning file searching tool from Mythicsoft.

FileLocator Pro offers a comprehensive set of features to help you locate and understand the
information on your computer.

What next? Check out the Getting started section for a quick introduction.

We want to ensure that you have a very positive experience with FileLocator Pro so please contact us
with any questions you may have:
techsupport@mythicsoft.com

1.1 Getting started

When you start FileLocator Pro it should look something like this:
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The interface is broken up into three main sections:
Criteria view, used to enter search criteria. If Expert User has been checked (the default) you will
see the Advanced Interface otherwise you will see the Basic Interface.

File list view, displays files found during search.

Contents view, displays various information about the search and the found files currently selected
in File List view.

Note: To change the look and feel of FileLocator Pro use the User Interface Settings.

Searching

When a search is started the searching animation starts. When searching through the contents of the
files information displaying amount of data to be searched is shown to help gauge how much longer the
search will take.

During a content search the progress shows the amount of data searched and the amount left to
search.

The search animation runs throughout the duration of the search.

As files are found they appear in the File list view. When searching through the contents of the files the
lines found can be viewed by selecting one or more of the found files. The lines found are then displayed
in the Contents view for each selected file.

1.2 Criteria View

FileLocator Pro provides two different interfaces, one for the experienced computer user, and the other
for the novice computer user who doesn't want to deal with some of the more advanced searching
features. To switch between the two interfaces toggle the 'Expert User' check box.
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User Interfaces:
Advanced Interface
Basic Interface

Saving

FileLocator Pro supports several saving options as described in the Sessions, Workspaces and Search
Criteria topic.

1.2.1 Advanced Interface

With Expert User checked the criteria section should look like this:

File name

File name filter, e.g. 
*.doc;*.txt;*.xls

to search all doc, txt, and xls files using the default expression type DOS Expression.

The equivalent regular expression would be 
\.(doc|txt|xls)$

To exclude a group of files prefix the DOS Expression with NOT:, e.g. NOT:*.doc;*.txt;*.xls. To make the
file name filter case sensitive click the 'Aa' buttons (a tick appears when switched ON).

For convenience there are also some preset file type collections in the list: Folders Only, Files Only,
Documents, Music, Pictures, and Videos.
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When a preset collection is picked the File name field is processed as a Boolean Expression.

Containing text

Specifies the contents to find in the files for a content search. The default expression type is Boolean.

To make the content search case sensitive click the 'Aa' buttons (a tick appears when switched ON).

Note: If the expression type is set to 'File Hash' then the containing text box can include a comma
separated list of hash values or a pointer to a file containing a list of hash values, e.g.
5A9C9B42A16F5E1985B7B0A019114C7A,675C9B42A16F5E1985B7B0A019114C7A

or,
=c:\FileHashTable.txt

The actual algorithms used to calculate the hash, e.g. SHA1, MD5, are specified in the Options tab.

Look In

The Look In field can specify various criteria for the search location including exclusion locations,
location filters etc. (for a full description of the advanced features see Look In). Multiple Look In locations
are separated by a semi-colon.

Browse for Folders button and Browse for Multiple Folders button provide a convenient mechanism to
select the folders to search. Press the 'Browse for multiple folders button' ...
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... and the multiple folders dialog will appear. Enter each folder on a separate line.

For more information on FileLocator Pro's advanced location features please read the Advanced Look In
and Persistent Search Filters pages.

Dates

Modified Before and After fields are used to search by file modified date. To activate the date criteria
either click on the button, i.e. After or Before, or the Calendar icon next to the value. See Date/Time
Selection for more information.

The other tabs available with the Advanced Interface are:

Options tab Options relating to the search, document processing etc
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Date tab Search by last accessed and created date.

Attributes tab Attributes to filter the search by, e.g. Read-only, Folders etc.

Scripting User Scripts for customizing search logic.

Compressed
Files tab

Compressed/Archive file searching

1.2.1.1 Options tab

Boolean Expression

Boolean expression search type defines whether Boolean expressions are matched on a line by line
basis or matched across the whole file.

For example "File AND Pro" on a line by line basis would find only lines with both File and Pro on them
and therefore only files where File and Pro both occurred on at least one line. However if matching
across the whole file the same expression would find files where both File and Pro occurred anywhere in
the file either on the same line or on different lines.

The 'Allow wildcards' option specifies whether or not the Boolean expression phrases will treat the
characters * or ? as wildcard characters.  For more information see Boolean Expressions.

Email Searching

The Outlook PST and MSG files checkbox switches on .PST and .MSG archive searching. By default
only the text of the email body will be searched but if Search attachments is checked email
attachments will also be searched. By default HTML based emails will be converted to text but if you
need to search the underlying HTML uncheck the Remove HTML markup check box.

For more information see Outlook PST Archive Searching and MSG File Searching

Enhanced File Searching

Selecting the 'Office/PDF documents' option instructs FileLocator Pro to perform extra processing of
common Office file formats that are registered on the computer. Without this option selected FileLocator
Pro will only search through the raw binary data of the file formats (unless the Exclude binary files
check box is switched on).
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Additional settings for how FileLocator Pro will search document file types is available by clicking the 
Settings... link which will open the Document Search Settings dialog.

The Exclude binary files option will exclude any files which contain non-printable characters.

Caching

Since the extra processing required to read document file formats can be time a time consuming
operation FileLocator Pro has a caching feature to temporarily save the processed text in a database.
When the caching feature is switched on FileLocator Pro first checks the cache database for the
processed text of the file before trying to process the actual file itself resulting in much faster searches.
The caching feature can be switched on by checking the Cache text option. 

Additional settings for the caching functionality is available by clicking the Cache... link which will open
the Cache Settings dialog.

1.2.1.2 Date tab

 
The date tab allows searching by last modified, created, and last accessed date.

Clicking the calendar buttons will open the Date/Time Selection Dialog.

Note: Any changes made to the modified date criteria are immediately reflected in the Main tab.

1.2.1.3 Attributes tab

The attributes tab allows filtering of files/folders based on their attributes.
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Each attribute can be one of three values:

-- Ignore the attribute.

On The attribute must be set on the file/folder.

Off The attribute must NOT be set on the file/folder.

1.2.1.4 Scripting tab

Scripting allows customization of the search engine's file name and contents matching algorithms
through any valid Active Scripting script.

It is possible to specify a script for either the file name matching rules or the containing text matching
rules. 

Set the Engine value to the appropriate Active Script engine Prog Id that will be used to run the script.
Two script engines are listed in the drop down, JScript and VBScript, but any installed script engine can
be specified.

Use the Parm field to pass additional parameters to the script.

The 'Test' button attempts to create the specified script engine, load the specified script into it, and
make a test call to the script, e.g. isValidFileName( "c:\", "TestFile.txt" ).

For more information please visit the Scripting page.
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1.2.1.5 Compressed Files tab

The Compressed Files tab shows the list of extensions relating to compressed/archive formats.

When a compressed file format is activated FileLocator Pro treats any files it finds of that type as part of
the file system folder hierarchy. e.g. c:\zips\file1.zip\compressed\doc.txt

1.2.1.6 Date/Time Selection

FileLocator Pro accepts various different date/time formats for filtering files based on the modified date/
time. To help specify the correct value the open the Date/Time Selection dialog by clicking on the
Calendar buttons shown above.
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Date/time values fall into one of two broad categories:
Fixed date/times - an absolute date/time value that stays the same on subsequent searches, e.g.
19/04/09 12:00
Relative date/times - a value that is relative to the moment the search is run, e.g. Today Start of hour

The dialog shows how the current selection evaluates at that point in time. It is constantly updated to
reflect the values of relative date and times.

Date values

Relative dates can be one of the following:

Today (Default) Date the search is run. e.g. 25/02/09
(Wednesday)

Start of week First day of the week when the search is run (Monday is
considered the start of the week).

e.g. 23/02/09
(Monday)

Start of month First day of the month when which the search is run. e.g. 01/02/09

Start of year First day of the year when the search is run. e.g. 01/01/09

End of week Last day of the week when the search is run (Sunday is
considered the last day of the week).

e.g. 01/03/09
(Sunday)
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End of month Last day of the month when the search is run. e.g. 28/02/09

End of year Last day of the year when the search is run. e.g. 31/12/09

Dates can be adjusted forward or back by any number of days, weeks, months, or years. For example
to set the date to be the first day of the previous week select 'Start of week' and then apply an
adjustment of '-1 Week'.

Time values

Relative times can be one of the following:

Now Time at the point the search is run. e.g. 13:24:52

Start of minute Time at the point the search is run with the seconds part set
to zero.

e.g. 13:24:00

Start of hour Time at the point the search is run with the minutes and
seconds part set to zero.

e.g. 13:00:00

Start of day (Default) Time is set to 00:00:00 e.g. 00:00:00

End of minute Time at the point the search is run with the seconds part set
to 59.

e.g. 13:24:59

End of hour Time at the point the search is run with the minute and
seconds part set to 59.

e.g. 13:59:59

End of day Time is set to 23:59:59 e.g. 23:59:59

Times can be adjusted forward or back by any number of seconds, minutes, or hours. 

Note: Relative date/times are evaluated at the point the search is started and are fixed to that value for
the duration of the search. The date/time is only re-evaluated at the start of the next search.

1.2.1.7 Document Search Settings

The Document Search Settings is opened from the Options tab.
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Note: The actual extensions listed will depend on each individual computer setup.

File formats with registered processing extensions (extensions specifically designed to help search
programs process the format) are shown in the list. If either Deep Search or specific extensions are
activated then FileLocator Pro will use the registered extension to process the file format prior to
searching. If the search fails or the extension fails to provide results then FileLocator Pro will also search
the raw file data if Deep Search or 'Also search raw document data of processed files' are specified.

1.2.1.8 Cache Settings

The Cache Settings dialog is opened from the Options tab.
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The cache is used to retain text extracted from processed document files, ie it does not cache text from
non-processed files such as .txt files. The dialog shows the amount of information used by the cache,
the maximum allowed size for any single document, and also the expiration policy for each document. 

Maximum document size relates to the size of the extracted text not the size of the original document
and defaults to around 10MB.

The default expiration is to remove any items from the cache if they have not been referenced in a search
in the last 60 days.

1.2.2 Basic Interface

With Expert User unchecked the criteria section looks more like the old classic Windows Find tool:
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Main features:
From the Main tab the fields Filename, Containing Text, and Look in can all be freely entered or
selected from previously used search criteria (note: last twenty values for each are retained).
The main difference between this and Windows Find is the 'Search Wizard...' button, which opens the
Search Wizard to walk the user through entering the criteria required for searching.

Options Tab

Main features:
File name, Contents, and Look In expression type.
'Match case' specifies if the searches are case-sensitive.

1.3 File List View

As files are found during the search they appear in the File List view. For each file its name and location
are displayed. All files selected in this view are shown in the Contents view.

FileLocator Pro supports context menus to list valid operations for a selected file or group of files.
Context menus will work on selections of multiple files but the list of valid operations will be reduced to
only the operations common to all selected files.

Column Filters
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Files can be temporarily filtered from the list through column filters. Click the Filter button (highlighted
below) to display the filter edit boxes.

The filters are applied immediately and can contain Boolean or type specific expressions:

Boolean
expressions

All column filters can accept Boolean expressions, e.g. tower NOT (bridge OR
hamlets)

Numeric
expressions

Numeric columns, such as Size and Hits, can be filtered on the text in the column
using Boolean expressions or the underlying numeric value. The greater than or less
than symbols are used to indicate numeric range filtering, e.g. > 10 < 20. The size
column also accepts Byte, KB, MB, or GB symbols.

Date/time
expressions

Date/time columns, such as Modified, Created, and Last Accessed columns, can be
filtered on the text in the column using Boolean expressions or the underlying date/
time value.  The greater than or less than symbols are used to indicate date/time range
filtering, e.g. > 20 Sep 2010. Date/times can be specified in any format accepted by
the standard Date/Time processing functionality including relative date times, e.g. <
Today -3 years.

1.4 Contents View

Any files selected in the File List view are displayed in the Contents view. 

Summary Tab

The summary tab simply provides a summary of the latest search:
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The four main values are:
1. Found Items: count and size of all the files that matched both the file name and containing text

criteria and are therefore displayed in the File List View.
2. Searched Items: count and size of all files that were searched after matching the file name criteria

(only applicable for content searches)
3. Checked Items: count and size of all files that were checked against the file name criteria
4. Search Status: Search status and total running time.

Hits Tab

When searching through the contents of files the Hits tab displays the found information, ie the hits, from
each of the selected files (click Select All from the Edit menu to see hits for all files). For non-content
searches only the file name is displayed.
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Lines that contain the search text are shown with the hit text highlighted in a different color. The highlight
color is by default blue but this can be changed to any color through Set Highlight Colour on the Edit
menu.

The expansion buttons next to the lines of text can be used to show surrounding lines of text as shown
below.
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The number of surrounding lines can be set via the Configuration dialog.

The file can be opened at the specified line by either double-clicking on the line or right-clicking on the
line to bring up the context menu and selecting "Open in New Window...". To open the file with an
external editor (e.g. Notepad++) select "Open in External Editor..." from the context menu. For more
information see Editor Settings.

Note: When displaying file contents the line number of each line found within the file is also displayed.
This line number is estimated by counting end of line markers within the file and therefore if the file
contains non-text information then the line numbers may not be accurate.

Text Tab

To view the hits in context of the actual file use the Text tab. The Text tab embeds the Internal File
Viewer into the Contents View for faster previewing of files:
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To open the file in a larger window choose 'Open in New Window...' option from the context menu or use
the Ctrl+Enter key combination.

Note: By default FileLocator Pro will open the file in Text tab when double-clicking on a hit in the Hits
tab. This default behaviour can be changed in the Editor Settings page.

Thumbnails Tab

When searching for pictures, or other graphical files, the Thumbnail tab provides a preview of the
selected files.
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Reports Tab

The reports tab provides an easy way to export, print, or summarize search data.
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More information on FileLocator Pro's reporting feature is available in the Reports topic.

Hiding/Docking the View

If displaying of content information is not important then it is often more efficient to hide the contents
view, especially with very large file selections. To hide the contents view either select 'Hide Contents
View' from the Contents View context menu or select the 'Window->Contents View->Hide' menu option.

To display the contents view below the file list view either select 'Dock Below' from the Contents View
context menu or select the 'Window->Contents View->Dock Below' menu option.

Printing

The Hits tab is the printable area of the application and prints whatever the user has selected in the File
List view. To print this view click Print or Print Preview from the File menu. 

1.5 Internal File Viewer

The Internal Viewer is a read-only display of the found file with the search hits highlighted. 
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Secondary
Search

Allows additional searches of the file to be performed by entering text in the 'Find'
edit box and hitting Enter.

Location Bar Provides an overview of the location of the lines shown in the File Contents in
relation to the rest of the file.

File Contents Displays the file opened at the line that was selected in the Contents View with
the found text automatically highlighted.

Content Menu

Additional operations are available through the context menu (right-click menu):
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Available commands:

Word Wrap Toggles word wrap on and off.

Copy Copies the selected text (shown in pale green) into the clipboard. If no text is
highlighted then the word at the current cursor position is copied. If the cursor is
not on a valid word then the whole line is copied.

Open in External
Editor

Opens the file at the current line in the external editor specified in Editor Settings
.

Open in Visual
Studio

Opens the file at the current line in Visual Studio (if Visual Studio is installed on
the machine).

Search Again Runs the original search again for the highlighted search text.

Find Performs a secondary search on the currently selected text. If no text selected
then the search uses the word at the current cursor position.

Find Next Moves to the next highlighted hit.

Find Previous Moves to the previous highlighted hit.

Highlight Original Toggles the highlighting of the original search hits.

Highlight Current Toggles the highlighting of the secondary search hits.

Set Font Selects the font used by the viewer. The default font is Courier New.

File Displays the Explorer shell menu for the file.

Highlighting

When a file is first opened the original found text is highlighted. If a secondary search is performed then
that is also highlighted but in a different color. Highlighting can be switched on and off by either using the
context menu or the short cut combinations Ctrl+Shift+O for original hits and Ctrl+Shift+C for secondary
hits.

Where hits from the original and secondary search overlap the hit is highlighted in red.

Navigation

To move to each of the highlighted hits either use the context menu or press F3 (or Shift+F3 to move
backwards). Navigation is always to the next highlighted match independent of whether that was from
the original or secondary search. Therefore, to only move through the secondary search hits turn off the
highlighting for the original search.

1.6 Search Navigation

Using search navigation it is possible to browse and/or reuse previous searches. Much like the forward
and back buttons on a web browser the search navigation buttons navigate backwards or forwards
through searches.
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The number of searches available for browsing is determined by the Search Navigation settings in the 
History Settings.

1.7 Favorites

Searches that are performed frequently can be saved as Favorites. Favorites are saved searches that
can be quickly loaded into the search panel for easy movement between different search types.

To access the Favorites functionality click the Favorite button on the toolbar (or press Ctrl+D):

This will open the Favorites pane and display any previously saved favorites.
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Adding a Favorite

To add a new favorite click the Add Favorite toolbar button:

which will open the Add a Favorite dialog:
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There are two values to associate with the favorite:

Descripti
on

A short meaningful description of the favorite

Tags (Optional) Tags that can be used to help group favorites and aid favorite filtering

Managing Favorites 

When you click on a favorite it will be loaded into the current search window. To load the favorite into a
new search window open the favorite's context menu and click 'Open in New Window'.

To filter the number of favorites displayed enter search terms in the 'Search' box. Any favorites that
include all the terms in either the Description or Tags (or combination of both) will be displayed.

Importing Favorites

Favorites are simply saved searches, ie SRF files, with just a little extra meta data for the description
and tags. Therefore you can import existing SRF files as favorites by copying them into the Favorites
folder. To open the Favorites folder click on the Open Favorites Folder toolbar button:
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1.8 Reports

FileLocator Pro's reporting feature provides a quick way to export, print and summarize search
information. There are four main reports: File List Report, Contents Report, Keywords Summary Report
and Keyword by File Report. All the reports can be customized to include/exclude different sections and
columns.

File List Report

The File List Report is very similar to the File List View and is only available in a Tabulated style. The
report only outputs file information, ie it does not output any of the found content.

Contents Report

The Contents Report is for reporting on the found content. In the Standard style the output looks similar
to the output displayed in the Hits tab.
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The report can also display information in a Tabulated style, which is better suited if you need to export
the information to a spreadsheet application.

Keyword Summary Report

Keyword statistics are displayed in the Keyword Summary Report. Each keyword is displayed along
with the total number of occurrences of that keyword found during the search. If the keyword includes
wildcard characters then the statistics are broken down into each separate keyword the keyword pattern



Introduction 35

Copyright © 2013 Mythicsoft Ltd. All rights reserved.

matches. The keyword breakdown can be disabled by removing the Keyword Hit column.

Keyword by File Report

While the Keyword Summary Report displays combined keyword hit statistics across the whole search
the Keyword by File Report breaks down the keyword statistics on a file by file basis.

Report Options

To customize the information shown in each report click the Options button (shown highlighted below).
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The Report Options lists the available columns for each report and which headers to display for the
report. The options shown below are for the Contents report.

1.9 Sessions, Workspaces and Search Criteria

FileLocator Pro allows search data to be exported in a number of different ways but while the Export
Results and Reports functionality is useful for exporting to common formats, such as Text, CSV, and
HTML, these formats can't be used to reload search data back into the application. For that FileLocator
Pro has three different save options: Search Criteria, Sessions, and Workspaces.

Search Criteria

The simplest save option (and the one used by the Favorites functionality) is to save just the Search
Criteria using the File -> Save Criteria menu option. The resulting SRF file can be used to load
FileLocator Pro's search criteria fields. 
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Note: The SRF file also contains the configuration settings at the time of the save but these are not
normally re-applied when the SRF file is loaded. However, by using the command line switch '-pc' the
current configuration can be reset to configuration settings at the same of the save.

Sessions

A single search tab is referred to as a Session and can be saved using the File -> Save Search menu
option. The resulting FLSX file contains the search criteria and search results for not just the current
search but also the search history for that search tab (if specified).

Workspaces

A Workspace consists of all the search Sessions and can be saved use the File -> Save Workspace
menu option. The resulting FLWX file contains the search criteria and search results for all the specified
search sessions.
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1.10 Hints & Tips

Searching for multiple
file types

You can search multiple files by using regular expressions or DOS
expressions. e.g. 
Searching the file types .cpp, .h, .c, .INL the regular expression would be:
\.(cpp|h|c|INL)$

OR, alternatively as a DOS expression it would be:
*.cpp;*.h;*.c;*.INL

Excluding file types Prefix DOS expression with NOT: to exclude certain file types from being
searched. For example, you can search everything but COM and EXE files
by setting the file name to the DOS Expression:
 NOT:*.exe;*.com

Searching multiple
locations

FileLocator Pro can search multiple folder paths. In the 'Look In' field
separate each folder with a semi-colon e.g. 
c:\winnt;c:\tmp

Using expressions in
the Look In field

Expressions are supported on folder paths, to use the feature use the
expression drop down list next to the Look In edit field. The expression is
not processed on the whole path but on the path parts, e.g.
c:\usr\dev\.*\release

would match all folders called "release" two levels down from the "c:
\usr\dev" folder.

Launching FileLocator
Pro from Windows
Explorer

FileLocator Pro can be integrated with the Windows Shell through the Shell
Extensions settings. For example, while browsing files and folders in
Windows Explorer you can launch FileLocator Pro by right-clicking on the
folder and selecting 'FileLocator Pro...' from the folder's context menu or
using the short-cut key combination Ctrl+F.

Common searches Save your most common search criteria as a SRF file and put a shortcut to
the file on the Start menu. Then when you open the shortcut FileLocator
Pro will start up with your most common search options.

Note: Make sure that FileLocator Pro is associated with SRF files in the 
Shell Integration settings.

Specifying default
values via the
command line

You can specify the initial values for FileLocator Pro through command line
parameters. There is even an option to switch off the GUI (Graphical User
Interface) and save the results directly to a file, useful when integrating
FileLocator Pro with other applications. To see a list of valid command line
parameters go to the "Help->Command Line Parameters" dialog (or run
FileLocatorPro.exe -h).

Performance effect of
word wrapping

Word wrapping is expensive, especially when trying to display a lot of
contents. If the Contents View display is slow consider switching Word
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Wrapping off.

Performance effect of
Contents View

If you are selecting a large number of files and do not need to see the
search contents of those files it is much quicker to turn the 'Contents View'
off, through the "Window->Contents View->Hide" menu option.

Performance effect of
two phase searching

FileLocator Pro works in a two phase process. The first phase collects a
list of files that match the File name criteria. The second phase searches
the contents of the files found in the first phase. If many files are found in
the first phase FileLocator Pro may use a significant amount of memory
resources maintaining the list of files. 

Therefore there is an option 'Single Phase' searching in the Options tab to
instruct FileLocator Pro to search the contents of the file as soon as the
File name is matched, avoiding the maintenance of an internal file list. The
only drawback to One Phase Searching is that FileLocator Pro cannot
display a progress meter. Use this feature for more memory efficient
contents searching of a large group of files (i.e. > 1,000,000), normally this
option is NOT required. 

Note: FileLocator Pro will automatically switch to single phase searching if
it detects a very large search.

Searching Unix and
Mac files

Unix and Mac text file formats use a different sequence to mark the end of
a line. Windows and DOS use the character sequence CR-LF (Carriage
Return - Line Feed) but Unix only uses LF and Mac only uses CR. To
instruct FileLocator Pro to look for alternative EOL (End of Line) sequences
go to the Configuration settings (via the menu option "Tools->Configuration")
and select Character Processing.

Testing regular
expressions

Test your regular expressions through the "Tools->Regular Expression
Tester" menu option.

More information can be found online at the Mythicsoft Knowledge Base: http://www.mythicsoft.com/kb.

1.11 Questions/Comments ?

More information is available in the Mythicsoft knowledge base:
http://www.mythicsoft.com/kb

and the Mythicsoft Questions and Answers site:
http://qa.mythicsoft.com/

Or please feel free to contact us with any questions or comments at: 
http://www.mythicsoft.com/filelocatorpro/support
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Or via email: support@mythicsoft.com

If you would like to purchase a registration code please visit the web site:
http://www.mythicsoft.com/filelocatorpro/buy

Thank you for using FileLocator Pro.
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2 Configuration

FileLocator Pro stores all its configuration information in XML files located, by default, in the Mythicsoft
AppData folder defined in the Folder Settings. The configuration information can be changed by clicking
on the Configuration button on the tool bar or by selecting the 'Configuration...' option from the 'Tools'
menu.

Configuration Window

The configuration information is presented as tree view of configuration groups and individual settings for
each group.

For more information visit the help page for each group:
General Settings
Expression Settings
Editor Settings
Advanced Settings
Extensions Settings
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2.1 General Settings

General settings are broken up into the following configuration groups:
History
Display
Search
Character Processing
Shell Integration
Sounds/Alerts
Localization
User Interface

2.1.1 History Settings

History settings control which information FileLocator Pro remembers about previous searches.

To clear the current history click the 'Clear History...' button. To clear the history every time FileLocator
Pro exists check the 'Clear all history on exit'.

Remember
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Options settings When checked FileLocator Pro restores options settings from the last
FileLocator Pro session, such as expression type, match case settings
etc.

Window size When checked FileLocator Pro restores the Window positioning from the
last FileLocator Pro session.

Load last search on
startup

When checked FileLocator Pro loads, on startup, the criteria used for the
last successful FileLocator Pro search. This option effectively overrides the
'Options settings' since the last search will include all the options.

Maximum List Sizes

Search
Navigation

The maximum number of searches shown in the search navigation list. Searches are not
remembered across FileLocator Pro sessions so the list is always initially empty.

Drop Down
Lists

The maximum number of items shown in the criteria drop down list boxes, e.g. File name,
Containing text, and Look in. These items are remembered across FileLocator Pro
sessions so the list from the previous session will be used to initialize the list of the new
session.

Recent
Files

The number of files shown in the Recent Files list on the File menu.

 

 

2.1.2 Display Settings

Display settings control how FileLocator Pro displays results.
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Display Lines

Max displayed lines per file Limits the number of lines that will be returned per file, to avoid errant
searches on very large file consuming too much memory. The default
is 10,000 lines.

Limit the maximum characters
displayed per line

When checked, limits the number of characters displayed in the
Contents View for each line (the abbreviated line is centered around
the found text on the line). 

If not checked the full line, as defined in the Character Processing
Settings, is displayed.

Surrounding lines

Sets the number of surrounding lines stored for each found line. Surrounding lines are shown in the
Contents View pane and can be seen by clicking on the '+' expand icon next to the found line. 

The settings only effects new searches so old searches will continue to display the surrounding lines
previously recorded.

File List View column settings

Display end of path - when checked FileLocator Pro gives priority to displaying the end of the path if the
whole path does not fit in the Location column. Directories at the beginning of the path are shortened to
'...', e.g. C:\...\...\...\cpp\ProjectOne\.
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2.1.3 Search Settings

Search settings define how FileLocator Pro searches files.

By default FileLocator Pro searches files in multiple phases. It first collects information about the files
specified in the 'File name' criteria and then, in a second phase, goes back and searches those files.
This allows FileLocator Pro to show more accurate progress information to the user. 

However, there are times that this may not be the preferred search method. For example on very large
searches where millions of files are being content searched or when the files are temporary and may
have moved or deleted between the first and the second phases a single phase search might be
preferable. To force FileLocator Pro to search each file as soon as it's located switch to 'Single phase'
search.

Note: FileLocator Pro automatically switches itself to single phase search if it detects that maintaining
the file search list is consuming too much memory.

The 'Display Hit Count' option specifies whether or not FileLocator Pro displays the number of hits found
within each file in the Hit column in the File List View. When this option is switched OFF FileLocator Pro
may search files in 'Just In Time' (JIT) search mode. 

JIT searching only searches enough of the file to decide whether or not it is a valid result and not
necessarily the whole file. The last search position in the file is recorded and the file is only completely
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searched when the full results are required for display or export. This can be useful for searching very
large files where the full results aren't necessarily required.

2.1.4 Character Processing Settings

Character processing settings control how FileLocator Pro handles information found in files.

End of Line (EOL) Identifiers 

Defines which other EOL identifiers FileLocator Pro should use. Normally a Windows text file will use a
CRLF (carriage return 0x0d, line feed 0x0a) combination to indicate the end of a line. However, other
operating systems use different standards, usually either a stand alone CR or a stand alone LF
character.

Maximum characters per line - sets the limit to the line length if an EOL character is not found. Lines
that exceed the maximum line length are broken into separate lines, although the line number for the line
stays the same.

Containing Text

By default a content based search will not include the file name as if it were part of the content. For
example, if a file named LondonHistory.doc was searched for Tower AND London the file would only be
found if both words appeared in the document text, ie the documents file name would not be included as
part of the text. The 'Include file name in content search' option is used to include the file name in the
content search.
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Special

Convert to 7-bit chars - when checked FileLocator Pro only uses the first 7-bits of each data character.
Some early word processors reserved the 8th bit of each character for formatting purposes, which if not
removed causes problems when searching the data. This setting causes the 8-th bit of every character
to be ignored.

2.1.5 Shell Integration Settings

Shell integration settings control how FileLocator Pro integrates into the Window shell.

Associate with SRF file
type

Associates FileLocator Pro with the extension SRF, the default extension for a
FileLocator Pro saved result file. When set double-clicking on an SRF file will
launch FileLocator Pro with the given SRF criteria file loaded.

Add to a Folder's
context menu

Adds FileLocator Pro to the context menu of folders and drives. This provides
a convenient way to launch FileLocator Pro for a given folder through right-
clicking on the folder and selecting 'FileLocator Pro...' from the context menu.

Add to a File's context
menu

Adds FileLocator Pro to the context menu of all files. This provides a
convenient way to use FileLocator Pro to search a limited selection of files
through right-clicking on a selection of files, and selecting 'FileLocator Pro...'
from the context menu.

Add to Find/Search Adds FileLocator Pro to the Windows Search menu.
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Start menu

Replace default
Explorer Search

Launches FileLocator Pro, instead of Windows Search, when Ctrl+F or F3 is
pressed in Windows Explorer.

Enable HotKey launch Enables launching of FileLocator Pro using the key combination
WinKey+Alt+F or WinKey+Alt+F3. 

Note: Hotkey support in enabled through the use of a small light weight
application called FLProHotKey that is added to the system start-up code.

Windows Vista: Since changing shell settings requires administrative privileges FileLocator Pro launches
a separate application, FLProShellAdmin.exe, to actually make the shell changes. FLProShellAdmin.
exe requires privilege escalation and therefore displays a UAC escalation request if UAC is enabled.

2.1.6 Sounds/Alerts Settings

Sounds and Alerts configuration optionally provides additional visual or audible notifications for different
FileLocator Pro events.

File Found

Play sound Specifies the wave file to play if a file is found. 

Show task bar notification
message

Specifies whether or not to show a notification window by the task bar
showing how many files have been found when a file is found. 

Repeat for every file found Causes the sound and task bar notifications to occur for every file found
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and not just the first file found (the default).

Search Finished

Play sound Specifies the wave file to play when the search finishes.

Show task bar notification
message

Specifies whether or not to show a notification window, by the task bar,
showing that the search has finished and how many files were found
during the search. 

2.1.7 Localization Settings

Localization settings specify which language should be used for the user interface.

2.1.8 User Interface Settings

User Interface settings control the FileLocator Pro 'Look and Feel'. 
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Default

FileLocator Pro is configured to use the Standard Theme and a tabbed user interface.

Classic

FileLocator Pro is configured to look and behalf like FileLocator Pro version 5.x, which uses the Classic
Theme and an MDI user interface.

Custom

User specified theme and option to use tabbed searching or not. 

To change the default file opening settings use the Editor Settings.

2.2 Expression Settings

Expression settings control the various matching rules for each of FileLocator Pro's expression engines.
This section is broken into:

Boolean Expression Settings
DOS Expression Settings
Regular Expression Settings
File Hash Settings
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2.2.1 Boolean Expression Settings

Boolean expression settings are used to control how the operators LIKE and NEAR behave.

LIKE Sensitivity

The LIKE operator can be configured for different sensitivity when matching search terms to similar
words. The possible settings are:

Very
similar

Only slight differences in words are accepted, e.g. a single character out of place.

Similar A wider range of similar words will be matched, e.g. for larger words multiple characters
can be out of place.

Approxima
te

Words only need a very approximate similarity to the search term to match.

NEAR Distance

By default the NEAR operator requires related search terms to be within 100 characters of each other.
This can be changed to a user defined limit. The lower the limit then the closer the terms need to be to
each other and vice versa.

Please see Boolean Expressions for more information on how to use Boolean Expressions.
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Expression Parsing

When pasting an expression into FileLocator Pro from a 3rd party application, such as Microsoft Word,
the quotes may appear stylized, e.g. “Tower London” OR “Canary Wharf”. The Process stylized quotes
as normal quotes option instructs FileLocator pro to convert those quotes into the standard quotes

FileLocator Pro uses to separate expressions, e.g. "Tower London" OR "Canary Wharf".

2.2.2 DOS Expression Settings

DOS expression settings specify whether the DOS expression matching rules will follow strict DOS
matching rules.

When set to 'Strictly conforming syntax' the DOS matching rules will force a boundary check at the
beginning and end of the expression if a wildcard character is found. e.g.

the expression locator* would NOT match the filename filelocatorpro.exe since it doesn't begin with the
term 'locator', instead the search term would need to be set to *locator*.

When the option has been switched off it is still possible to specify the boundary check using the '<' and
'>' characters, e.g.

the expression <locator*> is equivalent to Strict DOS expression locator*
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Please see Expression Types for more information about DOS Expressions.

2.2.3 Regular Expression Settings

Regular expression settings defines the regex syntax to use when searching. This can either be the Perl
compatible regular expression syntax or the Classic regular expression syntax. See Expression Types
for more information.

When searching for text in foreign languages it can often be useful to 'Collate character ranges' which
allows characters outside the standard a-z range to be included in the range, e.g. to include the é in
Années when using the range [a-z]+

2.2.4 File Hash Settings

File Hashing Settings specifies which hashing algorithms FileLocator Pro should use when searching for
a given file hash. 
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2.3 Editor Settings

Default Editor

FileLocator Pro by default uses its built-in file viewer to display a read-only view of a file's contents.
However, it is possible to change the default viewer to an external 3rd party editor by specifying the path
name and command line parameters for the external editor. Also, FileLocator Pro supports opening files
in Microsoft's Visual Studio.
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External Editor

To use an external editor specify the full path to the editor application and then, in the field below, any
command line parameters to be passed to the editor when it is launched. To pass the file name and line
number in the command line use the variables $(FILEPATH) and $(LINENUM).
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Common Editor Defaults - contains the preset settings to quickly set the command line parameters for a
few well known editors. To use these defaults simply select the editor from the drop down list.

2.4 Advanced Settings

Advanced settings are broken up into the following configuration groups:
File Lists
Folders
Junction Points
Threads/Priority
XSLT Processor

2.4.1 File Lists

File Lists indicate whether or not a criteria value can be loaded from a text file.
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Example: File name list

If the File name criteria allows file lists (the default setting) then instead of specifying:
*.c;*.cpp;*.h;*.hpp;*.inl;*.res;*.rc

the user could specify:
=C:\FileLists\CodeFiles.txt

with CodeFiles.txt containing something like:
*.c
*.cpp
*.h
*.hpp
*.inl
*.res
*.rc

adding each expression on a new line.

Example: Containing text list

To search for a list of keywords from a file switch on 'Containing Text' file lists and then specify the full
path to the keyword file in the 'Containing text' criteria field on the Main tab:
=C:\FileLists\Keywords.txt
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with Keywords.txt containing something like:
Telephone
Email
Contact

adding each keyword on a new line.

2.4.2 Folder Settings

Folder Settings specify the location that FileLocator Pro stores its configuration, log, and favorite files.

The default locations are:
$(ApplicationData)\logs\
$(ApplicationData)\config\
$(ApplicationData)\Favorites\

The $(ApplicationData) macro evaluates to the ApplicationData folder defined by Windows. On Windows
7 this is commonly:
C:\Users\<id>\AppData\Roaming\Mythicsoft\FileLocatorPro

Other macros available include $(FileLocatorProFolder) which evaluates to the installation location of
FileLocator Pro, e.g. 
C:\Program Files\Mythicsoft\FileLocator Pro

This can be very useful when installing FileLocator Pro to a USB drive so that all configuration
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information is kept on the USB drive and not stored in the computer.

The information changed in this dialog is stored in the master.xml file located in the root of the
FileLocator Pro installation folder.

2.4.3 Junction Points

NTFS Junction Points are links to other folders on the system. They are similar to symbolic links only
stronger, ie. referring to a junction point is for most intents and purposes the same as referring to the
folder itself.

By default FileLocator Pro will search junction points, apart from junction points that have the System
and Hidden attributes (which normally identify system junction points). 

2.4.4 Memory Manager Settings

If FileLocator Pro detects that it's consuming large amounts of memory it can truncate the search
results to reduce the amount of memory required. The Memory Manager Settings allow you to
customize the point at which truncation occurs or to switch off the functionality altogether.
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2.4.5 Threads/Priority Settings

Thread/Priority settings effect how FileLocator Pro uses the CPU.
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Concurrent threads

By default FileLocator Pro searches files using a single thread for each CPU core, which is usually the
most efficient configuration. However, it is possible to specify a different number of search threads by
unchecking the 'Auto Manage' option and specifying the thread count.

Warning: If a machine has a single slow hard drive increasing the number of search threads may slow
FileLocator Pro down since the concurrent searches could cause the hard drive to continually seek
between the different file disc sector locations. More often than not file searching is I/O bound rather than
processor bound.

Process priority

FileLocator Pro can be instructed to change its process priority depending upon the current state of the
application:

Foreground - the application has current user input focus.
Background - the application does not have current user input focus but has not been minimized.
Minimized - the application has been minimized.

By default the priority for all states is 'Normal', which is the standard setting for Windows applications.
The alternative priorities are:

High - the application process is given a higher priority than Normal processes but the priority is still
below processes with real-time priorities.
Low - the application process is given a lower priority than Normal processes but still receives a
reliable time-slice from the CPU. 
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2.4.6 XSLT Processor Settings

Save Results provides an option to run an XSL transform to provide custom formatting. FileLocator Pro
uses MS XML Core Services to provide the transform functionality but the actual DOM Prog Id can be
configured here.

2.5 Extensions

By default FileLocator Pro opens files in their raw binary format. While this works well for text based
formats other formats, such as ZIP files or MS Office 2010 files, do not work as well. Extensions help
FileLocator Pro in processing non-text based formats so that their underlying data is correctly retrieved
and searched. 
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Extensions are organized by:
IFilters - filters based around Microsoft's indexing service filter specification.
UTF-8 Default Format - file types that should, by default, be treated as UTF-8.
Compressed Document Formats - file types that are stored as ZIP files.
FileLocator Pro Extensions - filters based around Mythicsoft's in house filter specification.

2.5.1 IFilters

Microsoft Indexing Service uses filters, much like FileLocator Pro extensions, to interpret given file types
into easily searchable text. FileLocator Pro can use these indexing service filters, without the need to
run the indexing service, to help convert files into easily searchable text.
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The list of currently installed IFilters is shown in the IFilter settings tab. To use the IFilter activate it via
the Enhanced File Search settings in the Options tab 

A list of free IFilters can be found using a simple Internet search.

By default IFilters for HTML/XML based file types are not used because many users want to be able to
search the tags within an HTML document not just the text. However, if you want to search just the text
of HTML/XML files you can include the IFilters by checking the Include IFilters for HTML/XML based
file types.

The IFilter Search Priority determines which type of extension should be used for processing a file if
both an IFilter AND a FileLocator Pro specific processing extension are registered. By default IFilters
are Secondary, ie they will only be used if a FileLocator Pro specific extension is not found or could not
load the given file.

2.5.2 UTF-8 Default Format

If FileLocator Pro is unable to detect a file's encoding (through the BOM or XML header) it tries to read
the file as ASCII text. However, it is possible to override this behaviour and specify UTF-8 as the default
format for given file types.
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2.5.3 Compressed Document Raw Data Reader

When a document extension, such as DOC, is not active FileLocator Pro still tries to read the raw data
of the file. Some file types, however, such as Microsoft Office 2007 and Open Office use ZIP to
compress the document's data prior to storage, which requires FileLocator Pro to first unzip the
document file before searching the raw data.
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2.5.4 FileLocator Pro Extensions

Extensions help FileLocator Pro in processing non-text based formats so that their underlying data is
correctly retrieved and searched.
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The screenshot shows the configuration for the ZIP extension, which is used to read files in the ZIP
format. The configuration shows that the ZIP extension should be used for all files with a .zip or .jar
extension but could be changed to include any other zip based formats.

Safe Mode

An extension is normally run in the same process space as FileLocator Pro since it is the fastest way
for FileLocator Pro to communicate with the extension. However, running the extension in the same
process space does mean that if the extension has a catastrophic failure it can crash FileLocator Pro.
To avoid crashing FileLocator Pro troublesome extensions can be run in 'Safe Mode', which causes them
to run in their own process space, but it does mean that using the extension may cause FileLocator Pro
to run slightly slower.

Indexing Service Filter

While FileLocator Pro provides extensions for some well known file types, e.g. DOC, XLS etc, it is
sometimes faster to use Indexing Service Filters if they are available. The 'Use Indexing Service Filter'
check box instructs FileLocator Pro to try and find an Indexing Service Filter and use that instead of the
FileLocator Pro extension if one exists.

Note: Using an indexing service filter does not require the indexing service to be switched on merely that
the filter is installed on the machine.

Exclude file type from content searches when not active

Some file formats, such as ZIP, do not include useful searchable binary data within them so there is little
point in searching through the file if the extension has not been activated. To avoid wasting time
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searching through such file formats set the 'Exclude' flag.
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3 Advanced features

More information on advanced features:
Command line
Expression types
Boolean Expressions
Scripting
Look In
Persistent Search Filters
Unicode Support
Search within Search
Outlook PST Archive Searching
MSG File Searching

3.1 Command Line

FileLocator Pro's start up values can be altered through information passed through the command line. If
an output file is specified then the actual User Interface is not displayed and the results are streamed
directly to the file.

The available command line options are:

FileLocatorPro.exe [saved search] | -o [output file] | -oa | -oc | -ol
[num] | -oe? | -of? | -os | -d [folder name] | -c [containing
text] | -f [file name] | -cm | -fm | -s | -fd | -fx | -cr | -pa | -po |
-ma [datetime] | -mb [datetime] | -h | -?

-c Text to search for in specified files (i.e. the Containing Text field)

-ce? Contents expr type: -ceb=Boolean, -cex=Regular Expression, -cee=Plain Text, -
ceh=Boolean RegEx, -cew=Whole Word 

-cf Contents expression spans file (only valid with Boolean expressions)

-cm Match case when contents searching

-d Directory(s) to search (i.e. the Look In field), use -dw for current working directory

-f File names to search for

-fe? File name expr type: -fed=DOS, -fex=Regular Expression, -feb=Boolean, -fee=Plain Text, -
feh=Boolean RegEx

-fm Match case when comparing file names

-fx File name shows the file names to exclude

-le? Look In expr type: -leb=Boolean, -lex=Regular Expression, -lee=Plain Text

-ma Modified after date value, pass "now" as the date to use the current date and time

-mb Modified before date value, pass "now" as the date to use the current date and time

-o Output filename (runs the search without showing the FileLocator Pro GUI streaming results
directly to the file)

-oa Append to output file

-oc Output content lines

-oe? Output encoding: -oea=ASCII, -oe8=UTF-8, -oeu=Unicode, -oe8nb=UTF8 (no BOM), -
oeub=Unicode (big endian)

-of? Output format: -oft = Text (default), -ofc = CSV, -ofb = Tab, -ofx = XML, -ofh = HTML, -
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ofxslt=Custom (XSLT)

-ol Maximum number of found lines per file to output

-os Output surrounding lines of text

-pa Always use command line parameters when creating new or opening existing searches
Note: This option can be used to force a criteria value to be preset to a certain value
whenever the user creates a new search, regardless of the previously used value.

-pc Overwrite configuration with configuration stored in saved search criteria file.
Note: Configuration settings, such as active compressed file types (e.g Zip) or character
processing settings, are not normally loaded from the SRF file. This option forces the loading
of the configuration settings from the SRF file, effectively setting FileLocator Pro to the
identical state it was in when the SRF file was saved.

-po Override values from file when loading from file AND specifying command line parameters

-r Start search immediately (implied by -o option)

-re? Regular expression type: -rep=Perl syntax, -rec=Classic syntax

-
rese
tui

Resets the user interface to the default size and position, ie toolbars, menu, docked windows
etc. are reset to the installation defaults.

-s Search subfolders

-view Open a file in the Internal Viewer (use -viewline and -viewcol to specify line and column)

-h or
-?

Show the help dialog

To switch an option off append 'n' to the flag, e.g. 
FileLocatorPro.exe -fmn Switches OFF match case when comparing files

Examples:

To launch FileLocator Pro with the Look In field pre-filled with "C:\Documents and
Settings\user\My Documents" the command line arguments would be:

FileLocatorPro.exe -d "C:\Documents and Settings\user\My Documents"

To run a search looking for files that match *.sys in the folder C:\WINDOWS without launching
the usual user interface but instead streaming the results directly to an output file the command
line arguments would be:

FileLocatorPro.exe -d "C:\WINDOWS" -f "*.sys" -o "c:\temp\results.txt"

To launch FileLocator Pro with Search subfolders switched off and Match case on contents
searching switched on the command line arguments would be:

FileLocatorPro.exe -cm -sn
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3.2 Expression Types

FileLocator supports the following expression types:
Boolean
Boolean RegEx
Whole Word
DOS
Exact match
Regular expression
File Hash

Boolean Expressions

Boolean expressions combine individual search phrases using the AND, OR, NOT, LIKE and NEAR
operators. For more information see Boolean Expressions.

Boolean RegEx Expressions

Boolean RegEx expressions are a special type of Boolean expression that allow regular expressions to
be combined using the AND, OR, and NOT operators. For more information see Boolean Expressions.

Whole Word Expressions

Whole Word expressions match the search phrases exactly as typed ignoring partial word matches.
Since Whole Word expressions are a special type of Boolean expression individual search phrases can
be combined using the AND, OR, and NOT operators. For more information see Boolean Expressions.

DOS Expressions

DOS expressions are usually used to specify groups of files. Use a semi-colon to specify multiple
groups, e.g.

The expression *.cpp;*.h searches for files that end with .cpp or .h

The characters '<' and '>' can be used to match the beginning and end of a file name, e.g.

The expression <file* only matches files that begin with the term file and NOT files that simply
have the term file in them.

For more information see DOS Expressions.

Plain Text

Plain text matching will match the text as entered (ie literally).

Regular Expression
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FileLocator Pro can be configured to use Perl compatible regexp syntax or the Classic FileLocator Pro
syntax in the Options tab. Basic regular expression can be built using the Expression Wizard

Classic syntax

FileLocator Pro's classic regexp syntax is based on the most commonly used regular expression
elements, more information can be found in the Quick Start section.

Perl compatible syntax

Perl compatible regexp syntax is based around the Boost regular expression engine and includes not
only the functionality of the 'classic' regular expression engine but also additional Perl style expression
enhancements detailed here: http://www.boost.org/doc/libs/release/libs/regex. 

File Hash

If the content type is set to File Hash then each file is put through a number of hashing algorithms (as
defined in the Options tab). The resulting hashes are returned as lines in a text file with each hash on a
new line. The specified Containing text value is matched against each hash in the list.

3.3 Boolean Expressions

FileLocator Pro's Boolean expression engine supports Web style search expressions using the AND,
OR, NOT, NEAR, REGEX, and LIKE operators. FileLocator Pro can be configured to match the
expression across the whole file (default) or on a line by line basis in the Options Tab.

Line by Line example

The expression work AND document searches for lines that include the words work and
document. Since FileLocator Pro implicity assumes an AND the expression can alternatively be
written as work document.

The expression work OR document searches for lines that include either 'work' or 'document'.

The expression work NOT document searches for lines that include 'work' but not 'document'.

Whole file example

The expression work AND document searches for files that include the words work and
document. The words can occur on the same line or on different lines throughout the file.

The expression work NOT document searches for files that include work but not document
anywhere in the file.

Note: the operators AND, OR, and NOT must be written in capital letters otherwise they are assumed to
be search terms.

Quotes can be used to search for literal phrases, e.g. 
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"work document" searches for the exact phrase work document.

Brackets can be used to specify phrase grouping, e.g. 

The expression work AND (document OR letter) searches for lines that include work and either
document or letter.

LIKE Operator

If the spelling of the search term is unsure, or possibly misspelled in the search text, the LIKE operator
can be used to specify an approximate search term. For example,

LIKE necessary

will find necessary but also slight variations such as neccessary. The scale of the approximation can be
changed in the Configuration settings.

NEAR Operator

To specify that two search terms should be near to each other in the search text use the NEAR
operator. For example,

work NEAR document

will only match the two terms if they are within a certain number of characters of each other (the
maximum character distance is specified in the Configuration settings). 

REGEX Operator

To specify that a term is a regular expression use the REGEX operator. For example,

work AND REGEX "\d{5,6}"

will match any document that has the term work and the regex \d{5,6} (ie. a number with 5-6 digits) in it.
To specify that terms should always be treated as regular expressions, ie without the need to use the
REGEX operator, use the Boolean RegEx expression type (see below).

LINES Operator

The LINES operator limits the lines that are searched for the following expression. For example,

LINES:3-5 (tower AND london)

searches only lines 3, 4, and 5 for the expression tower AND london.

Boolean Sub Expressions

Boolean expressions are comprised of sub expressions. The sub expression type will depend on the 
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Expression Type chosen

Boolean (no

wildcards1)

Each phrase is matched exactly as typed but will match against partial words.
e.g. 
fish will match against the words fish, fishing and selfish.

Boolean (with

wildcards1)

Allows wildcard characters '*' and '?'. '?' will match any single character and '*' will
match zero or more characters until the end of the word.
e.g. 
fish* will match against the words fish, fishing, and selfish.

The wildcard setting also allows word boundary matching using the '<' and '>'
characters to specify the beginning or end of the word, e.g.

<fish> will match against only the whole word fish and not fishing or selfish. Similarily
fish> would match both fish and selfish but not fishing since the word must end with
fish.

To search for the literal text fish* or fish> put the search term in quotes, e.g. "fish*" or
"fish>"

Boolean RegEx Each phrase is treated as a regular expression. If the regular expression includes
spaces or parenthesis use quotes to group the expression together.
e.g.
trout.* OR "fish(es|ing)"

Whole Word Each phrase is matched exactly as typed.
e.g.
fish will match against only the word fish and not fishing or selfish.

1 The wildcard setting is specified in the Options tab (the default is to allow wildcards).

Example: Boolean RegEx

By using the Boolean RegEx expression type regular expression searches can be combined using the
operators AND, OR, and NOT. The regular expressions are evaluated on each line but the behaviour of
the Boolean combination of those regex results, ie line by line or across whole file, is defined by the
Boolean Expression settings in the Options Tab.

Line by Line example

The expression [0-9]+ AND document searches for lines that include both a number and the
word document.

The expression "[a-z]+@[a-z]+" NOT "\.(com|net)" searches for lines with email like text but not
including .com or .net. Note the use of quotes to show the regular expression grouping
(otherwise the brackets would have been treated as a boolean grouping).

Whole file example
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The expression "([0-9]+\.){3}[0-9]+" AND error searches for files with an IP address and the
word error somewhere in the file but not necessarily on the same line.

Quotes are used to identify parts of the expression that are regular expressions.

Note: Due to the complex nature of the Boolean RegEx expression type searches using it are usually
slower than with the other expression types. Therefore use of Boolean RegEx is only recommended
when its specific capabilities are required.

3.4 DOS Expressions

DOS Expressions use the familiar wildcards * and ? to specify groups of files, e.g. *.pdf to specify a
group of files with the PDF extension. However, FileLocator Pro extends the normal DOS expression
functionality with some additional special characters:

Char
acte

r

Description Example

* Matches zero or more
characters

Tower*London - file/folder with Tower followed by London in their
name.

? Matches any single character *.as?x - files with a four letter extensions that begin with AS
and end X, e.g. Page.aspx or Home.ascx.

< Start of file indicator <New - file/folder must begin with New, eg. New York Trip.txt
but not My New Recipes.

> End of file indicator LA> - file/folder must end in LA, eg. Parks in LA OR Details.
SLA but not LAMP.

; Expands search by adding
another allowable name/group

*.pdf;*.txt;*.doc - files with PDF, TXT and DOC extension.

: Restricts search to only those
with a specified name/group

*.pdf;*.doc:London - PDF or DOC files that have London in their
name.

NOT: Excludes a name/group from
the search

NOT:*.dll;*.exe;*.sys - all files except DLL, EXE, and SYS files

| Concatenate multiple search
expressions

*.pdf:London|*.txt:Tower - PDF files with London in their name
OR TXT files with Tower in their name.

" Used to either quote semi-colon
';' character or specify word
boundary

"LA" - file/folder with the word LA in their name, eg. LA Flight
details.txt but not LAMP.txt.

More Examples

Searching For DOS Expression

Files/folders without any extension *.

Only files/folders with the specific
name Area

<area>
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PNG, JPG, or BMP files with the
word France in them

*.png;*.jpg;*.bmp:France

MP3 files with the word Rolling AND
Stone in them

*.mp3:Rolling:Stone

PDF files with either the word
London OR Tower in them

*.pdf:London;Tower

All files that are not EXE or DLL
files with the word Flower in the
name

NOT:*.exe;*.dll:Flower

Any TXT file with a semi-colon in it "*;*.txt"

3.5 Scripting

FileLocator Pro supports Active Scripting to customize the search engine's file name and contents
matching algorithms. 

When the user starts a search FileLocator Pro:
Looks to see if any script is active
Creates the Active Scripting engine for each script as specified by the Prog Id entered in the 'Engine'
field.
Loads the script into the scripting engine.

Once the script is loaded FileLocator Pro will then call a specific function inside the script depending on
the script type:

If the script is a 'File Name' script the function called is 'isValidFileName' and is passed the file path
and name as parameters.
If the script is a 'Containing text' script the function called is 'isValidLine' and is passed the line
number and text as parameters.

Scripts are only called if the other search criteria is satisfied, i.e. file name or containing text
expressions. The functions should return a boolean true or false value to indicate if the file or line is valid
or not.
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Examples:

Note: Please see the "Sample Scripts" sub-folder of the main FileLocator Pro installation folder for some
provided sample scripts.

Read-only script

The following example shows a sample file name script to limit the files returned to those that have the
Read-Only attribute specified. Note: Other attributes could be used, e.g. use the '32' instead of '1' to find
files with Archive attribute specified.

var objFSO = new ActiveXObject( "Scripting.FileSystemObject" );

function isValidFileName( strPath, strFileName )
{

var bIsValid = false;

try

{

var objFile = objFSO.GetFile( strPath + strFileName );

bIsValid = ( objFile.Attributes & 1 );

}

catch( e ) {}

return bIsValid;
}

Note that try...catch blocks have been used to prevent exceptions being thrown back to the search

engine. If an exception occurs and is not caught by the script the search will stop.

Folders only script

Another example shows how to locate only folders.

var objFSO = new ActiveXObject( "Scripting.FileSystemObject" );

function isValidFileName( strPath, strFileName )
{

var bIsValid = false;

try

{

bIsValid = objFSO.FolderExists( strPath + strFileName );

}

catch( e ) {}

return bIsValid;
}

NOT expression script

Here's an example of how to implement NOT when contents matching using JScript's own regular
expression engine (the NOT expression to be matched is entered in the 'Containing text' CustomParm
field on the Scripting tab):
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// An example of a NOT expression, this time using JScript's built in
Regular Expression object.

var regExp = new RegExp( SearchParms.ContainingTextCustomParm );

function isValidLine( nLineNum, strText )
{

var bIsValid = true;

try

{

bIsValid = !regExp.test( strText );

}

catch( e ) {}

return bIsValid;
}

Note how the regular expression object is created outside of the function body so that it is only created
and compiled once for any given search, although it may be called many times.

Excluding directories

Another variation of the NOT expression (see above) is for excluding certain directories from a search.
For example, to exclude the Windows directory from a search the NOT expression on the path is simply
'C:\\Windows'. Here's an example of how to implement a NOT when path name matching (the NOT
expression to be matched is entered in the 'File name' CustomParm field on the Scripting tab):

// An example of a NOT expression on a file's pathname
// using JScript's built in Regular Expression object.

var regExp = new RegExp( SearchParms.FilenameCustomParm );

function isValidFileName( strPath, strFileName )
{

var bIsValid = true;

try

{

bIsValid = !regExp.test( strPath );

}

catch( e ) {}

return bIsValid;
}

Note the use of two '\\' to represent a single '\' in 'C:\\Windows' since the backslash character is the
special escape character in regular expressions.

Search Parameters Object

Scripts can access almost all the other search criteria through the object 'SearchParms'. For example,
the isValidFileName script could use the Custom Parm value entered in the Scripting tab like this:

var strCustom = SearchParms.FilenameCustomParm;
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SearchParms provides access to the following criteria:

CurrentFileName (String) - Currently being processed file name.

CurrentFilePath (String) - Path of currently processed file.

ContainingText (String) - Value entered in the 'Containing text' field..

ContainingTextCustomParm (String ) - Value entered in the 'Custom Parm' field for containing text script.

ContainingTextRegExp (Boolean) - Indicates if the regular expression on Containing text has been
switched on.

EOLUnix (Boolean) - Indicates if EOL Unix option has been switched on.

EOLMac (Boolean) - Indicates if EOL Mac option has been switched on.

Filename (String) - Value entered in the 'File name' field.

FilenameCustomParm (String) - Value entered in the 'Custom Parm' field for file name script.

FilenameExcludeExp (Boolean) - Indicates if the 'Specifies NOT expression' has been switched on.

FilenameRegExp (Boolean) - Indicates if the regular expression on File name has been switched on.

LookIn (String) - Value entered in the 'Look in' field.

MatchFilenameCase (Boolean) - Indicates if the match case option for file name has been switched on.

MatchContentsCase (Boolean) - Indicates if the match case option for the containing text has been
switched on.

ModifiedAfter (Date) - Value entered in the 'Modified After' field.

ModifiedBefore (Date) - Value entered in the 'Modified Before' field.

SearchContents (Boolean) - Indicates if the search is searching contents of files.

SearchOnePhase (Boolean) - Indicates if  'One Phase Searching' has been switched on.

SearchSubFolders (Boolean) - Indicates if the 'Search Sub Folders' has been switched on.

SizeMoreThan (Integer) - Value entered in the 'Size More Than' field.

SizeLessThan (Integer) - Value entered in the 'Size Less Than' field.

3.6 Look In

Often the Look In field simply specifies a single folder to search through. However, the Look In field can
accept much more than just a single folder location.
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Types of values accepted in the Look In field:

Single folder e.g. c:\work\doc

Expression Expressions can be specified for individual parts of the folder paths, i.e. The
expression is not on the whole path but the path parts, e.g. the regular expression
c:\usr\dev\.*\release 

would match all folders called "release" two levels down from the "c:\usr\dev" folder.

Single file e.g. c:\work\doc\file.txt

Multiple files/
folders

Multiple entries are separated with a semi-colon, e.g.
c:\work\doc;c:\work\email;c:\work\logs\special.log

Exclusion files/
folders

An exclusion location is identified by an exclamation sign, e.g. to exclude the audit
sub folder
c:\work\doc;!c\work\doc\audit

Location filters Filters are expressions applied against the folder for each search item to allow
groups of items to be easily targeted. A filter starts with either a plus or minus sign,
e.g. to exclude all the Subversion source control sub folders (named '.svn')
c:\work\source;-.svn

or, to include only the accounting sub folders while still excluding the Subversion
sub folders
c:\work\source;+account;-.svn

Lookup Lists A lookup list is a list of locations to search, each one put on a new line, retrieved
from an external file. A lookup list is identified by an equal sign, e.g.
=c:\lookup\accountsource.txt

and the contents of the accountsource.txt file could be something like:
c:\work\source
c:\work\tools
+account
-.svn

Macros Macros identify common locations on a Windows machine. The macros are
evaluated for the host system each time the search is run, which is useful if
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creating search criteria that may run across a number of different machines. 

$(AdministrativeTools)
$(AllLocalDrives)
$(ApplicationData)
$(ApplicationDataDrive)
$(CommonAdminTools)
$(CommonApplicationData)
$(CommonDesktopFolder)
$(CommonDocuments)
$(CommonDocumentTemplates)
$(CommonFavourites)
$(CommonMyMusic)
$(CommonMyPictures)
$(CommonMyVideo)
$(CommonProgramFiles)
$(CommonProgramsGroup)
$(CommonStartMenu)
$(CommonStartup)
$(DesktopFolder)
$(DocumentTemplates)
$(Favourites)
$(Fonts)
$(InternetCache)
$(InternetCookies)
$(InternetHistory)
$(LocalApplicationData)
$(MyDocuments)
$(MyDocumentsDrive)
$(MyMusic)
$(MyNetwork)
$(MyPictures)
$(MyPrinters)
$(MyVideo)
$(Profile)
$(ProgramFiles)
$(ProgramsGroup)
$(Recent)
$(SendTo)
$(StartMenu)
$(Startup)
$(SystemFolder)
$(WindowsFolder)
$(WindowsInstallDrive)

Environment
variables

Any environment variable set up for the computer/application can be used in the
Look In field, e.g.

%TEMP%;%CLASSPATH%

could be used to search all the folders indicated by the TEMP and CLASSPATH
environment variables setup for the computer.
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Persistent Search Filters

When a filter is so common that it should be used for every search, such as excluding source code
meta data files, it can be setup as a persistent search filter.

A persistent search filter can be any valid Look In value and when active is appended to the Look In value
for every search. More information is available on the Persistent Search Filters page.

3.7 Persistent Search Filters

Location filters are often used to include or exclude certain search locations for a given search. Some
filters are so common that they are desired for every search, e.g. excluding source code meta data
folders. Persistent Search Filters allow the definition of such common search filters which (while active)
are applied to all searches.

When one or more persistent search filters are active a red check mark is shown on the filter button:

Clicking on the filter button opens the Persistent Search Filters dialog showing the list of filters and their
active status:
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To change a filter double-click on the filter or to add a new one click the 'Add...' button. 

A search filter is normally a location filter, such as -archive, but can actually be any valid Look In value.
Multiple values can be semi-colon separated, e.g.
-.svn;-archive

All active search filters are appended to a search's Look In value at time of search.
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3.8 Unicode Support

File System Unicode Support

FileLocator Pro is built with the Windows Unicode libraries and therefore supports searching of the file
system with full Unicode support.

Content Searching Unicode Support

Content searching of files processed by extensions (such as IFilters) supports Unicode searching if the
underlying format supports Unicode.

Text file searching supports Unicode if the file can be identified as Unicode, either by a Byte Order
Marker (BOM) or an XML encoding declaration at the beginning of an XML file. The Unicode types
supported are UTF-16LE, UTF-16BE, and UTF-8.

Binary searching of non-identifiable file types, such as EXE etc., is carried out using an ASCII search
unless otherwise specified in the UTF-8 Default Format settings.

3.9 Search within Search

Sometimes it is preferable to limit subsequent searches to the result list or a subset of the result list.
FileLocator Pro supports searching file subsets through two menu options:

File - Search Result List Searches all files listed in the result list. 

File - Search Current
Selection

Searches all files that are currently selected in the result list.

Search within search works by creating a new search and pre-filling the Look In field with all the files to
be searched. 

3.10 Outlook PST Archive Searching

FileLocator Pro is able to search through all PST archives from the older Outlook 97 right up to the latest
versions. Also, since FileLocator Pro 'understands' the actual underlying file format it doesn't require
Outlook to be installed and can also bypass the password protection and encryption present on most
PST files. However, since FileLocator Pro is not dedicated to searching only PST files it can appear a
little confusing as to how PST searching works. The overwhelming temptation is to use the file name
field to identify the PST archive, e.g. *.pst, instead of the item within the PST archive, such as an email,
that you are looking for. 

FileLocator Pro basically treats each individual Outlook item, ie an email, contact, calendar item etc.,
within a PST file as a separate file. The 'file name' for each item is dependant on the item type, e.g. for
email messages the email's subject is used as the file name. So to search a PST file follow these steps:

1. Specify the location of the PST files (or a specific PST file) in the 'Look in' field
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The location can include Outlook folders within the PST files.

2. Switch on PST Searching in the Options Tab

Without the PST format switched on the PST archive is treated as a normal file and simply searched
using its binary content. If the 'Search attachments' option is checked then the attachments for each
email are also searched, otherwise only the main email body is searched.

3. Use the 'File name' field to search by email subject and 'Containing text' to search by email
content.
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Each result is shown as a text file, which can be copied or dragged to another location. The results can
also be explored using the Internal Viewer just like normal results.

Searching multiple PST files

The above example shows how to search through a single PST file but FileLocator Pro can search
multiple PST files in a single search. Instead of specifying a single PST file in the Look In field simply
specify the folder (or the root of the sub-tree) where the PST files are located. To ensure that only pst
files are searched add the location filter +.pst, e.g. 

C:\Folder\Email;+.pst

To export the email and/or attachments to separate files simply copy/paste or drag/drop the required
files to a location in Explorer.

3.11 MSG File Searching

MSG file searching is activated through the Options tab.



Advanced features 89

Copyright © 2013 Mythicsoft Ltd. All rights reserved.

When activated FileLocator Pro treats MSG files as containers of other files, ie. MSG files become
'virtual' folders. The body of the email text is treated as a single .txt file and each of the email's
attachments as separate files (assuming the 'Search attachments' option has been checked). Therefore
when searching MSG files it's important to avoid the temptation of specifying the filename as *.msg
since there are few emails which will contain *.msg in their subject line. Instead use Location Filters to
restrict the search to just msg files, e.g.

C:\Folder\Emails\;+.msg

To export the email and/or attachments to separate files simply copy/paste or drag/drop the required
files to a location in Explorer.

Example 1: Searching MSG files by Subject and Contents

The example below shows how the 'File name' field is used to search the email Subject while the
'Containing text' field is used to search the email body. Note that the File name field has been switched
to Boolean search for more flexible searching.

Example 2: Searching MSG files for image attachments

This example uses the 'File name' field to search for attachments that are either PNG, JPG, or BMP
files.

Important: Make sure that Search attachments has been checked in the Options Tab.
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3.12 Export Results

For exporting results FileLocator Pro provides both the Reports functionality and the File -> Export
Results menu option. The Export Results dialog allows the results to be saved either to the clipboard or
to a specified file. 
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The results can be saved in a variety of formats:

Comma
separated
(CSV)

Comma separated table of results (best format for saving results for subsequent opening
in Excel).

HTML HTML formatted results, designed to look similar to the Hits tab view.

Tab
separated

For content searches the information is grouped by file, similar to Hits tab. The Tab
character (ASCII 09) is used to separate values.

Tab
separated
(spreadsheet
)

Tab separated table of results, similar to CSV but using the Tab character (ASCII 09) to
separate the columns (best format when saving to clipboard and then pasting into
Excel).

Text Text based format designed to look similar to Hits tab view.

XML XML formatted results. 

Custom formatting

For advanced formatting XSL transforms can be used to customize the output format. XSL transforms
are a text based language for defining data transformations and can be used to convert FileLocator Pro's
XML data into a desired format. Sample transforms are included in the Sample Transform subfolder and
include:

Contents_No
LineNumbers
.xsl

Exports just the found contents with no other information included, such as file data or
line numbers.
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FileName_O
nly.xsl

Exports just the file name without any path information, each file is exported on a
separate line.

FullName_Fil
eSizeBytes.
xsl

Exports the full file name (ie with path) along with the size in bytes of the file.

Hash_Separa
ted.xsl

Exports the file name information separated by the '#' character. 

Hits_Only.xsl Exports just the hits found in a search, i.e. without any file information or extra found
text information. Useful for regular expression searches to output text that matches a
given expression, e.g. extracting telephone numbers, or email addresses. This transform
differs from Unique_Hits_Only.xsl in that it will output all hits of the found text, ie it will
output duplicate hits.

HTMLTransfo
rm.xsl

Exports the data in a format very similar to the standard HTML export.

Unique_Hits_
Only.xsl

Exports just the hits found in a search, i.e. without any file information or extra found
text information. Useful for regular expression searches to output text that matches a
given expression, e.g. extracting telephone numbers, or email addresses. This transform
differs from Hits_Only.xsl by only outputing the unique hits, i.e. it only outputs the value
of the hit once regardless of how many times it may actually be found.

xcopy.xsl Generates XCOPY statements to copy from one drive to another preserving folder
structure.
    
For each file an XCOPY command is generated with only the drive letter replaced in the
source path. e.g.

C:\folder1\folder2\filename1.txt

generates:
xcopy "C:\folder1\folder2\filename1.txt" "E:\folder1\folder2\*"

NOTE: The XSL file needs to be edited to change target from E: to desired target drive.
Does not work with UNC paths. e.g. \\server1\folder1\folder2
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4 Wizards

To help the user with some of FileLocator Pro's complex features two wizards are available:
Search wizard (Basic interface only)
Expression wizard (Advanced interface only)

4.1 Search Wizard

Search Wizard walks the user through entering the basic search criteria with examples and performance
tips.

The user is presented with three pages asking for the following pieces of information:
Name of the file.
Contents of the file.
Location of the file.

On the final page if the 'Start the search automatically' check box is checked the search will begin when
the user clicks Finish.

4.2 Expression Wizard (Expr Wiz)

Expression Wizard walks the user through creating a basic regular expression. The Expression Wizard
can be used for building expressions to search for either the file name or the file contents.

Note: The term 'string' is used as a generic term referring to either the file name or file contents.
Basically a string is any word or group of words which, if you think about it, is exactly what a file name
is.

First page (Introducing the Expression Wizard)

The first page of the wizard is just an introduction for the Expression Wizard with notes for the particular
type of expression being built (i.e. a note for file name and a different note for file contents).

Second page (Create the Expression)

The second page is where all the work takes place. It should look something like this:
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Shown above is an example expression for a file name and will find any file name that includes the
phrase 'MyFile' followed by any character followed by any number and finally ending with '.txt', i.e. a text
file. Therefore it would find files such as 'Dave_MyFile54.txt' or 'MyFile_Num2.txt' but would not find the
files 'MyFile.txt', 'A_MyFile34a.txt', or 'MyFile34.doc'.

If you think back to how regular expressions work the layout of the Expression Wizard should become
apparent. A regular expression is built out of a number of 'entries'. There is one beginning entry, multiple
main body entries, and one final end entry. Each entry has a specific type:

Don't know. The value of the entry is unknown. e.g. The beginning of the file name may be
unknown.

Any character. Matches to any single character.
The character. Matches to a character entered by the user in the Text field.
Any one of these characters. Matches to any one of the characters entered by the user in the

Text field.
Any character except these. Matches to any character except the ones entered by the user in

the Text field.
The phrase. Matches to the specific phrase entered by the user in the Text field.
Space(s). Matches to a space.
Any numeric character. Matches to any numeric character, i.e. 0-9.
Any text character. Matches to any alphabetic character, i.e. a-z.

Once the user has specified the entry type and the text, if required for the entry type, then the user
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needs to specify the number of occurrences of that entry:
Zero or once. The entry type may or may not be there but if it is then it maps to one occurrence.
Zero or many times. The entry type may or may not be there but if it is then it can map to one or

more occurrences.
Once only. The entry type must be there and is mapped to only one occurrence.
Once or many times. The entry type must be there and can map to many occurrences.

The Expression Wizard does not currently provide all the functionality of regular expressions. However, if
the user knows how to construct their own regular expressions they can enter the any part of a regular
expression by adding an entry of type 'The phrase' and putting the regular expression in the Text field.

The entries can be rearranged using drag and drop.

Third page (Warning: Special characters entered)

When the user has finished entering the regular expression the user can normally press Finish to feed
the regular expression back to the main search window. However, if the user has entered any special
characters (i.e. characters that have special meaning in a regular expressions) in the Text field for any
entry then the Finish button actually changes into a Next button and the user is warned that special
characters were entered. The user then has two choices, either to have FileLocator Pro convert the
special characters so that they will not be treated as special (default) or to leave the expression as it is
because the user specifically entered special characters.

In the screen shot shown above you can see that this is exactly what happened with the example. The '.'
in '.txt' is the wildcard character and therefore instead of a Finish button there is a Next button. If you
look at the resulting expression you'll see that the '.' has been prefixed with the '\' escape character. This
happened automatically because of the default action, which is to convert the special characters so that
they are not treated as special. This page (i.e. the third page) allows the user to turn that default action
off.
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5 Regular Expressions

FileLocator Pro provides extensive regular expression support using either a Perl compatible syntax or a
classic syntax. 

Perl compatible syntax

Perl compatible regexp syntax is based around the Boost regular expression engine and includes not
only the functionality of the 'classic' regular expression engine but also additional Perl style expression
enhancements detailed here: 
http://www.boost.org/doc/libs/1_51_0/libs/regex/doc/html/boost_regex/syntax/perl_syntax.html

Classic syntax

FileLocator Pro's classic regexp syntax supports the most commonly used regular expression
elements, which is the subject of this section. To continue go to the Quick Start section.

5.1 Quick Start

FileLocator Pro includes a regular expression engine as one of its Expression Types. Regular
expressions (some times shortened to regexp) provide a concise language to describe exactly what to
search for. In very basic terms you can split an expression into two parts:
- what you are looking for
- the number of occurrences you want to find of it.

So let's take an example:
1. I want to find all files named abc, abbc, abbbc, abbbbc etc. So basically I want to find all files that
begin with 'a' followed by one or more 'b' then followed by 'c'. The expression would be:
ab+c

Breaking that apart we read:
- find one occurrence of 'a'
- find at least one occurrence of 'b' (the '+' indicates 'one or more')
- find one occurrence of 'c'

The characters that specify the number of occurrences are:
+ one or more
* zero or more
? zero or one

So ab?c would find any file named abc or ac (i.e. there can be zero or one 'b').

A very important regexp character is the period '.' (the wildcard character) because it matches to ANY
character. So a.c would match to aac, abc, acc, adc, aec, afc, a1c, a6c etc. And if we combine that
with an occurrence character we can start producing some useful expressions:
dave.*vest

breaks down to:
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- find one occurrence of 'd'
- then one occurrence of 'a'
- then one occurrence of 'v'
- then one occurrence of 'e'
- then zero or more occurrences of ANY character
- then one occurrence of 'v'
- then one occurrence of 'e'
- then one occurrence of 's'
- then one occurrence of 't'

and so matches to 'davevest', 'dave vest', 'dave is wearing a vest'.

There are other regexp characters and tricks on the following pages. More detail on regular expressions.

5.2 What is a regular expression?

A regular expression is a way of describing a group of words (referred to as a 'string'). It allows a user to
build a complex set of rules to describe exactly what characteristics the string should have. While this
documentation uses the word string you can think of a string as either a filename when searching for a
filename using regular expressions, or as text in a document when using a regular expression to search
the contents of files.

The simplest regular expression is a sequence of letters, numbers, or both. Such a regular expression
matches any string that contains that sequence. For example:

The regular expression `foo' matches any string containing `foo'. So if you wanted to find a file
with the letters 'fred' in it the regular expression would simply be 'fred'.

This is obviously a very simple example but you can express complicated rules. For example:

To find a file that begins with 'July' or 'August' followed at some point by 'Document' or
'Documents' followed at some point by a number and has a '.doc' extension the expression
would be: '̂ (July|August).*Documents?.*[0-9]+.*\.doc$'

This expression would find:
JulysPrivDocuments_23.doc
August Documents Num5a.doc
etc.

Don't worry if the expression above looks confusing because it is. That is why FileLocator Pro includes
an Expression Wizard to guide you through building regular expressions using common English terms.

For more information please read regular expression basics.

Note: You can test out your expression against the FileLocator Pro regular expression engine through
the 'Tools' -> 'Regular Expression Tester...' menu option.

5.3 Regular expression basics

Regular expressions use special characters (also known as regular expression operators) to specify
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rules for strings. A summary of these characters are:

^ Beginning of string
$ End of string
. Any character
[ Start of character list
] End of character list
( Start of expression group
) End of expression group
| ORs two expressions
\ Escape character
* Preceding expression occurs zero or more times
? Preceding expression occurs zero or one times
+ Preceding expression occurs one or more times

5.4 *, ?, + (Occurrence characters)

Specifies the number of occurrences of the preceding character or group. In a regular expression there
are four possible choices when trying to specify how many occurrences the regular expression should
match to:

Zero or one, the '?' character.
Zero or many, the '*' character.
One or many, the '+character.
Exactly one, the character itself not followed by any occurrence character.

For example:

If you entered the filename as the expression 'complaint ?doc' it would find all files that had the
word 'complaint' followed by zero or one space followed by 'doc'. Therefore it would find files
such as 'my complaint doc.doc' and 'mycomplaintdoc.txt', but would NOT find files such as 'my
complaint_doc.doc' or 'my complaints doc.doc'.

If you entered the filename as the expression '̂ my.*doc$' it would find all files that began with
the word 'my' followed by zero or more characters ending with 'doc' (note the use of '̂ ' beginning
of string, '.' any character, and '$' end of string special characters). Therefore it would find files
such as 'my_note.doc', 'my_owndoc', and 'my_specialfile.doc' but would NOT find 'my_note.txt',
'thisis_my_note.doc'.

If you entered the filename as the expression '_file[0-9]+' would find all files that had the word
'_file' followed by one or more numbers (note the use of '[' and ']' character list special
characters). Therefore it would find files such as 'my_file245.doc' and 'the_file0023.txt' but would
NOT find 'a_file_34.txt' or 'some_file 009.txt'.
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5.5 \ (Escape character)

Escape character is used to suppress the special meaning of other special characters. 

For example:

The expression 'Cost$' will match a string ending with 'Cost' whereas the expression 'Cost\$' will
match a string that contains 'Cost$'. As you can see the escape character suppressed the
special meaning of the '$' end of string character.

The expression 'file.txt' will match a string that contains 'file' followed by any character followed
by 'txt, whereas the expression 'file\.txt' will match a string that contains 'file.txt'. This time the
escape character suppressed the meaning of the special character '.' any character.

Finally, the expression to actually search for the '\' character is preceded with the '\', i.e.
suppress the escape character, e.g. to search for '3\4' use the expression '3\\4'.

5.6 | (Expression OR)

Use the | when either one expression or another will do. 

For example:

Both the expressions '(stabilised|stabilized) condition' and 'stabili(z|s)ed condition' will match
'stabilised condition' and 'stabilized condition'.

'(1|2|3) (person|people)' will match '1 person' and '2 people' and '3 people' but will not match '4
people' (it will also match '2 person' etc.). Note: this expression could have also been expressed
using a character list.

5.7 (...) (Expression group)

Parentheses are used for grouping in regular expressions as in arithmetic. They are often used with the 
'|' OR functionality to group alternatives.

For example:

The expression '12 Mar(ch)? 2000' would find the string '12 March 2000' and '12 Mar 2000'. Note
the use of the '?' zero or more occurrence character.

If you entered the filename as the expression '̂ myfile\.(txt|doc)$' it would find any file that whose
name was 'myfile.txt' or 'myfile.doc'. Note the use of the '̂ ' beginning of the string character, the
'\' escape character to treat the '.' in '.txt' literally, and the '$' end of the string character. 

5.8 [...] (Character lists)

Specifies a list of characters that are valid in the string. Characters can be listed individually or a range
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of characters can be indicated by giving two characters and separating them by a '-'. For example, '[abc]'
will match any of the characters 'a', 'b', or 'c'; this is the same as '[a-c]', which uses a range to express
the same set of characters. 

You can match the characters not within a range by complementing the set. This is indicated by using a
'̂ ' as the first character in the list (note: this is the same character as the beginning of string character).
For example, '[ 5̂]' will match any character except '5'.

Multiple ranges are allowed. E.g., the list '[A-Z0-9]' is a common way to express the idea of "all
alphanumeric characters." To include one of the characters `\', `]', `-' or ` '̂ in a character list use the '\'
escape character.

For example:

The expression '[0-9]+' will find any number in a string (note the use of the '+' occurrence
character).

The expression '[0-9]+/[0-9]+/[0-9]+' is a expression that could be used to search for dates
within a string. Although it does not check the validity of the date it is unlikely that any other
string would be match that pattern.

5.9 . (Wildcard character)

Matches any single character. It is used to specify an unknown portion in the string. Because the period
is used in almost all Windows file names it is very common to forget that it has a very special meaning
in regular expressions. If the user wishes to use the period literally in a search it must be preceded by
the '\' escape character. For example: 

If you entered the filename as the expression 'mydoc.doc' it would find any file that had 'mydoc'
followed by any character followed by 'doc'. Therefore although it would find 'mydoc.doc' it would
also find 'mydoc1doc' and 'mydocXdoc'. If you wanted to just search for 'mydoc.doc' the
expression would be 'mydoc\.doc'.

Example:

If you entered the filename as the expression '̂ mydocument..\.txt$' it would find any file that
began with 'mydocument' followed by exactly any two characters and ended with '.txt' (note the
use of the '̂ ' beginning of the string character, and the '\' escape character to treat the '.' in '.txt'
literally, and the '$' end of the string character). Therefore it would find files such as
'mydocument_1.txt' and 'mydocument1a.txt' but would not find files such as 'mydocument.txt'
and 'mydocument_1a.txt'.

The expression 'my.*\.txt' would find any file that includes 'my' followed by any number of
characters followed by '.txt' (note the use of  '*' to specify zero or more occurrences). Therefore it
would find files such as 'my_examples.txt' and 'this is my file.txt.doc' but would not find files
such as 'myfile.doc' and 'm_y_file.txt'.
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5.10 $ (End of string)

Matches the end of a string (to match the beginning of a string use '̂ '). 

For example: 

If you entered the filename as the expression 'complaint\.doc$' it would find all files that ended
with 'complaint.doc' (note the use of the '\' escape character for the '.'). Therefore it would find
files such as 'bank_complaint.doc' and 'my_complaint.doc' but would not find files such as
'some_complaint.txt' or 'some_complaint_2.doc'.

5.11 ^ (Beginning of string)

Matches the beginning of a string (to match the end of a string use '$'). 

For example:

If you entered the filename as the expression '̂ win' it would find all files that began with the
name 'win'. Therefore it would find files such as 'winhelp.exe' and 'windows_questions.txt' but
would not find files such as 'Copy of winhelp.exe' and 'some_winfile.txt.

5.12 Other Examples

AND

Although the regular expression engine does not directly support the concept of the boolean AND
operation it can, in a limited way, be simulated. e.g.

To search for a line containing 'error' AND 'log' the expression would be '(error.*log)|(log.*error)'.
Basically the different possible combinations have been combined, i.e. find 'error' followed by
'log' OR find 'log' followed by 'error'. While this works for a small number of words it does become
infeasible with a larger number of words.

Obviously the simplest way to specify an AND style expression is to use the Boolean expression
engine.
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